The file preview functionality in Jirafeau < 4.4.0, which is enabled by default, could be…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The file preview functionality in Jirafeau < 4.4.0, which is enabled by default, could be exploited for cross site scripting. An attacker could upload image/svg+xml files containing JavaScript. When someone visits the File Preview URL for this file, the JavaScript inside of this image/svg+xml file will be executed in the users' browser.
Why it matters now
EPSS 0.00609 49th percentileScored 2026-11-07
Fix Fixed mojo42/jirafeau (Packagist): 4.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mojo42/jirafeau (Packagist) | before 4.4.0 | 4.4.0 | Patch available | GHSA-j2xf-p274-g8cc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mojo42/jirafeau (Packagist) Vendor— Affected before 4.4.0 Fixed in 4.4.0 Patch available GHSA-j2xf-p274-g8cc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jirafeau:jirafeau:*:*:*:*:*:*:*:* | before 4.4.0 | Vulnerable | Jirafeau project |
- cpe:2.3:a:jirafeau:jirafeau:*:*:*:*:*:*:*:* Versions before 4.4.0 Vulnerable ·Jirafeau project
Remediation
- Fix · GHSA-j2xf-p274-g8cc mojo42/jirafeau (Packagist) Fixed in 4.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-30110
- 2026-10-03 Alias added: GHSA-j2xf-p274-g8cc
References
More Jirafeau project Jirafeau vulnerabilities
- TI-2018-08092 The administration panel of Jirafeau before 3.4.1 is vulnerable to three CSRF attacks on… CVSS 3.0HIGH 8.8
- TI-2018-08094 script.php in Jirafeau before 3.4.1 is affected by two stored Cross-Site Scripting (XSS)… CVSS 3.0MEDIUM 6.1
- TI-2018-09646 An issue was discovered in Jirafeau before 3.4.1. CVSS 3.0MEDIUM 6.1
- TI-2018-09645 An issue was discovered in Jirafeau before 3.4.1. CVSS 3.0MEDIUM 6.1
- TI-2018-08093 An issue was discovered in Jirafeau before 3.4.1. CVSS 3.0MEDIUM 6.1
- TI-2026-01163 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Jirafeau CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-30110 · CVE Program
- CVE-2022-30110 · NVD
- FIRST EPSS
- GHSA-j2xf-p274-g8cc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences