Cross-site scripting in https://github.com/concrete5/concrete5
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
XSS in /dashboard/blocks/stacks/view_details/ - old browsers only. When using an older browser with built-in XSS protection disabled, insufficient sanitation where built urls are outputted can be exploited for Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 to allow XSS. This cannot be exploited in modern-day web browsers due to an automatic input escape mechanism. Concrete CMS Security team ranked this vulnerability 3.1with CVSS v3.1 Vector AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N. Sanitation has been added where built urls are output. Credit to Credit to Bogdan Tiron from FORTBRIDGE (https://www.fortbridge.co.uk/ ) for reporting
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/concrete5/concrete5 | Remediated in Concrete CMS 8.5.8 and 9.1.0. Affected Versions are Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 | — | No fix listed | CNA |
| — | concrete5/core (Packagist) | 9.0.0 to before 9.1.0 | 9.1.0 | Patch available | GHSA-m2ww-6wv6-vw3c |
| — | concrete5/core (Packagist) | before 8.5.8 | 8.5.8 | Patch available | GHSA-m2ww-6wv6-vw3c |
- https://github.com/concrete5/concrete5 Vendor— Affected Remediated in Concrete CMS 8.5.8 and 9.1.0. Affected Versions are Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 Fixed in — No fix listed CNA
- concrete5/core (Packagist) Vendor— Affected 9.0.0 to before 9.1.0 Fixed in 9.1.0 Patch available GHSA-m2ww-6wv6-vw3c
- concrete5/core (Packagist) Vendor— Affected before 8.5.8 Fixed in 8.5.8 Patch available GHSA-m2ww-6wv6-vw3c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 8.5.8; 9.0.0 to before 9.1.0 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 8.5.8; 9.0.0 to before 9.1.0 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-m2ww-6wv6-vw3c concrete5/core (Packagist) Fixed in 9.1.0 Advisory →
- Fix · GHSA-m2ww-6wv6-vw3c concrete5/core (Packagist) Fixed in 8.5.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-30120
- 2026-10-03 Alias added: GHSA-m2ww-6wv6-vw3c
References
Advisory 4
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-30120 · CVE Program
- CVE-2022-30120 · NVD
- FIRST EPSS
- GHSA-m2ww-6wv6-vw3c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences