Read the docs
TI-2022-12497 Aliases CVE-2022-30241GHSA-qp2q-6h9j-jg2r

The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape…

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.

Why it matters now

EPSS 0.00715 53rd percentileScored 2026-11-07
Fix Fixed jquery.json-viewer (npm): 1.5.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—jquery.json-viewer (npm)before 1.5.01.5.0Patch availableGHSA-qp2q-6h9j-jg2r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • jquery.json-viewer (npm) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-qp2q-6h9j-jg2r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jquery_json-viewer_project:jquery_json-viewer:*:*:*:*:*:node.js:*:*up to 1.4.0VulnerableJquery Json-viewer Project
  • cpe:2.3:a:jquery_json-viewer_project:jquery_json-viewer:*:*:*:*:*:node.js:*:* Versions up to 1.4.0 Vulnerable ·Jquery Json-viewer Project

Remediation

  • Fix · GHSA-qp2q-6h9j-jg2r jquery.json-viewer (npm) Fixed in 1.5.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-30241
  2. 2026-10-03 Alias added: GHSA-qp2q-6h9j-jg2r

References

Sources