Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.
Why it matters now
EPSS 0.00602 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed neos/neos (Packagist): 4.4.0, 5.3.10, 7.0.9 +4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | neos/neos (Packagist) | 3.3.0 to before 4.4.0 | 4.4.0 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 5.3.0 to before 5.3.10 | 5.3.10 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 7.0.0 to before 7.0.9 | 7.0.9 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 7.1.0 to before 7.1.7 | 7.1.7 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 7.2.0 to before 7.2.6 | 7.2.6 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 7.3.0 to before 7.3.4 | 7.3.4 | Patch available | GHSA-7m9h-v68w-pfw3 |
| — | neos/neos (Packagist) | 8.0.0 to before 8.0.2 | 8.0.2 | Patch available | GHSA-7m9h-v68w-pfw3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- neos/neos (Packagist) Vendor— Affected 3.3.0 to before 4.4.0 Fixed in 4.4.0 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 5.3.0 to before 5.3.10 Fixed in 5.3.10 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 7.0.0 to before 7.0.9 Fixed in 7.0.9 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 7.1.0 to before 7.1.7 Fixed in 7.1.7 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 7.2.0 to before 7.2.6 Fixed in 7.2.6 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 7.3.0 to before 7.3.4 Fixed in 7.3.4 Patch available GHSA-7m9h-v68w-pfw3
- neos/neos (Packagist) Vendor— Affected 8.0.0 to before 8.0.2 Fixed in 8.0.2 Patch available GHSA-7m9h-v68w-pfw3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:neos:neos_cms:*:*:*:*:*:*:*:* | 3.3.0 to before 5.3.10; 7.0.0 to before 7.0.9; 7.1.0 to before 7.1.7; 7.2.0 to before 7.2.6; 7.3.0 to before 7.3.4; 8.0.0 to before 8.0.2 | Vulnerable | neos |
- cpe:2.3:a:neos:neos_cms:*:*:*:*:*:*:*:* Versions 3.3.0 to before 5.3.10; 7.0.0 to before 7.0.9; 7.1.0 to before 7.1.7; 7.2.0 to before 7.2.6; 7.3.0 to before 7.3.4; 8.0.0 to before 8.0.2 Vulnerable ·neos
Remediation
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 4.4.0 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 5.3.10 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 7.0.9 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 7.1.7 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 7.2.6 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 7.3.4 Advisory →
- Fix · GHSA-7m9h-v68w-pfw3 neos/neos (Packagist) Fixed in 8.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-30429
- 2026-10-03 Alias added: GHSA-7m9h-v68w-pfw3
References
Advisory 2
More Neos Cms vulnerabilities
- TI-2023-19191 Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-30429 · CVE Program
- CVE-2022-30429 · NVD
- FIRST EPSS
- GHSA-7m9h-v68w-pfw3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences