Cross-site scripting in Jenkins Application Detector Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Application Detector Plugin 1.0.8 and earlier does not escape the name of Chois Application Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00786 56th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:app-detector (Maven): 1.0.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Application Detector Plugin | up to 1.0.8 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:app-detector (Maven) | before 1.0.9 | 1.0.9 | Patch available | GHSA-6wh8-mr6f-6cx2 |
- Jenkins Application Detector Plugin VendorJenkins Affected up to 1.0.8 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:app-detector (Maven) Vendor— Affected before 1.0.9 Fixed in 1.0.9 Patch available GHSA-6wh8-mr6f-6cx2
Remediation
- Fix · GHSA-6wh8-mr6f-6cx2 org.jenkins-ci.plugins:app-detector (Maven) Fixed in 1.0.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-30960
- 2026-10-03 Alias added: GHSA-6wh8-mr6f-6cx2
References
Sources
- CVE-2022-30960 · CVE Program
- CVE-2022-30960 · NVD
- FIRST EPSS
- GHSA-6wh8-mr6f-6cx2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences