Cross-site scripting in Jenkins Multiselect parameter Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Multiselect parameter Plugin 1.3 and earlier does not escape the name and description of Multiselect parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00767 55th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:multiselect-parameter (Maven): 1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Multiselect parameter Plugin | up to 1.3 | — | No fix listed | CNA |
| — | io.jenkins.plugins:multiselect-parameter (Maven) | before 1.4 | 1.4 | Patch available | GHSA-h3v9-46pp-h33w |
- Jenkins Multiselect parameter Plugin VendorJenkins Affected up to 1.3 Fixed in — No fix listed CNA
- io.jenkins.plugins:multiselect-parameter (Maven) Vendor— Affected before 1.4 Fixed in 1.4 Patch available GHSA-h3v9-46pp-h33w
Remediation
- Fix · GHSA-h3v9-46pp-h33w io.jenkins.plugins:multiselect-parameter (Maven) Fixed in 1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-30964
- 2026-10-03 Alias added: GHSA-h3v9-46pp-h33w
References
Sources
- CVE-2022-30964 · CVE Program
- CVE-2022-30964 · NVD
- FIRST EPSS
- GHSA-h3v9-46pp-h33w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences