Integer Overflow in Vapor's HTTP Range Request
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
Vapor is an HTTP web framework for Swift. Users of Vapor prior to version 4.60.3 with FileMiddleware enabled are vulnerable to an integer overflow vulnerability that can crash the application. Version 4.60.3 contains a patch for this issue. As a workaround, disable FileMiddleware and serve via a Content Delivery Network.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vapor | vapor | before 4.60.3 | 4.60.3 | Patch available | CNA |
| — | github.com/vapor/vapor (SwiftURL) | before 4.60.3 | 4.60.3 | Patch available | GHSA-vj2m-9f5j-mpr5 |
- vapor Vendorvapor Affected before 4.60.3 Fixed in 4.60.3 Patch available CNA
- github.com/vapor/vapor (SwiftURL) Vendor— Affected before 4.60.3 Fixed in 4.60.3 Patch available GHSA-vj2m-9f5j-mpr5
Remediation
- Fix · CNA vapor (vapor) Fixed in 4.60.3
- Fix · GHSA-vj2m-9f5j-mpr5 github.com/vapor/vapor (SwiftURL) Fixed in 4.60.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31005
- 2026-10-03 Alias added: GHSA-vj2m-9f5j-mpr5
References
Advisory 2
More Vapor vulnerabilities
- TI-2022-13064 DoS Vulnerability in URLEncodedFormDecoder in Vapor CVSS 3.1HIGH 7.5
- TI-2024-14356 Integer overflow in URI leading to potential host spoofing CVSS 3.1MEDIUM 6.5
- TI-2023-23892 Incorrect request error handling triggers server crash in Vapor CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-31005 · CVE Program
- CVE-2022-31005 · NVD
- FIRST EPSS
- GHSA-vj2m-9f5j-mpr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences