SMTP Command Injection in iCalendar Attachments to emails via newlines in Nextcloud Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Nextcloud server is an open source personal cloud server. Affected versions were found to be vulnerable to SMTP command injection. The impact varies based on which commands are supported by the backend SMTP server. However, the main risk here is that the attacker can then hijack an already-authenticated SMTP session and run arbitrary SMTP commands as the email user, such as sending emails to other users, changing the FROM user, and so on. As before, this depends on the configuration of the server itself, but newlines should be sanitized to mitigate such arbitrary SMTP command injection. It is recommended that the Nextcloud Server is upgraded to 22.2.8 , 23.0.5 or 24.0.1. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | before 22.2.8; 23.0.0 to before 23.0.5; 24.0.0 to before 24.0.1 | 22.2.8, 23.0.5, 24.0.1 | Patch available | CNA |
- security-advisories Vendornextcloud Affected before 22.2.8; 23.0.0 to before 23.0.5; 24.0.0 to before 24.0.1 Fixed in 22.2.8, 23.0.5, 24.0.1 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | before 19.0.13.7 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* | before 22.2.8 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 20.0.0 to before 20.0.14.6; 21.0.0 to before 21.0.9.5 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* | 23.0.0 to before 23.0.5 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:-:*:*:*:*:*:* | 24.0.0 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta1:*:*:*:*:*:* | 24.0.0 beta1 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta2:*:*:*:*:*:* | 24.0.0 beta2 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta3:*:*:*:*:*:* | 24.0.0 beta3 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:rc1:*:*:*:*:*:* | 24.0.0 rc1 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:rc2:*:*:*:*:*:* | 24.0.0 rc2 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions before 19.0.13.7 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* Versions before 22.2.8 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 20.0.0 to before 20.0.14.6; 21.0.0 to before 21.0.9.5 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* Versions 23.0.0 to before 23.0.5 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:-:*:*:*:*:*:* Versions 24.0.0 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta1:*:*:*:*:*:* Versions 24.0.0 beta1 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta2:*:*:*:*:*:* Versions 24.0.0 beta2 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:beta3:*:*:*:*:*:* Versions 24.0.0 beta3 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:rc1:*:*:*:*:*:* Versions 24.0.0 rc1 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:24.0.0:rc2:*:*:*:*:*:* Versions 24.0.0 rc2 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 22.2.8, 23.0.5, 24.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31014
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences