Invite bypasses user approval in Discourse
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-285.
Summary
Discourse is an open source platform for community discussion. Prior to version 2.8.4 on the `stable` branch and 2.9.0beta5 on the `beta` and `tests-passed` branches, inviting users on sites that use single sign-on could bypass the `must_approve_users` check and invites by staff are always approved automatically. The issue is patched in Discourse version 2.8.4 on the `stable` branch and version `2.9.0.beta5` on the `beta` and `tests-passed` branches. As a workaround, disable invites or increase `min_trust_level_to_allow_invite` to reduce the attack surface to more trusted users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | before 2.8.4; 2.9.0.beta1 – 2.9.0.beta4 | 2.8.4 | Patch available | CNA |
- discourse Vendordiscourse Affected before 2.8.4; 2.9.0.beta1 – 2.9.0.beta4 Fixed in 2.8.4 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* | before 2.8.4 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:*:*:*:* | 2.9.0 beta1 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:*:*:*:* | 2.9.0 beta2 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:*:*:*:* | 2.9.0 beta3 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:*:*:*:* | 2.9.0 beta4 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* Versions before 2.8.4 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:*:*:*:* Versions 2.9.0 beta1 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:*:*:*:* Versions 2.9.0 beta2 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:*:*:*:* Versions 2.9.0 beta3 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:*:*:*:* Versions 2.9.0 beta4 Vulnerable ·discourse
Remediation
- Fix · CNA discourse (discourse) Fixed in 2.8.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31025
References
Patch 4
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences