Malicious response from KubeEdge can crash CSI Driver controller server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-476.
Summary
KubeEdge is built upon Kubernetes and extends native containerized application orchestration and device management to hosts at the Edge. In affected versions a malicious message response from KubeEdge can crash the CSI Driver controller server by triggering a nil-pointer dereference panic. As a consequence, the CSI Driver controller will be in denial of service. This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. At the time of writing, no workaround exists.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | kubeedge | before 1.9.3; 1.10.0 to before 1.10.1 | 1.9.3, 1.10.1 | Patch available | CNA |
| — | github.com/kubeedge/kubeedge (Go) | 1.10.0 to before 1.10.1 | 1.10.1 | Patch available | GHSA-x938-fvfw-7jh5 |
| — | github.com/kubeedge/kubeedge (Go) | before 1.9.3 | 1.9.3 | Patch available | GHSA-x938-fvfw-7jh5 |
- kubeedge Vendorbackstage Affected before 1.9.3; 1.10.0 to before 1.10.1 Fixed in 1.9.3, 1.10.1 Patch available CNA
- github.com/kubeedge/kubeedge (Go) Vendor— Affected 1.10.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-x938-fvfw-7jh5
- github.com/kubeedge/kubeedge (Go) Vendor— Affected before 1.9.3 Fixed in 1.9.3 Patch available GHSA-x938-fvfw-7jh5
Remediation
- Fix · CNA kubeedge (kubeedge) Fixed in 1.9.3, 1.10.1
- Fix · GHSA-x938-fvfw-7jh5 github.com/kubeedge/kubeedge (Go) Fixed in 1.10.1 Advisory →
- Fix · GHSA-x938-fvfw-7jh5 github.com/kubeedge/kubeedge (Go) Fixed in 1.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31077
- 2026-10-03 Alias added: GHSA-x938-fvfw-7jh5
References
Patch 2
Advisory 2
More backstage Kubeedge vulnerabilities
- TI-2022-13117 KubeEdge Edge ServiceBus module DoS CVSS 3.1HIGH 7.5
- TI-2022-13120 Malicious Message can crash CloudCore in KubeEdge CVSS 3.1MEDIUM 5.7
- TI-2022-13119 KubeEdge DoS when signing the CSR from EdgeCore CVSS 3.1MEDIUM 6.5
- TI-2022-13124 KubeEdge Websocket Client in package Viaduct: DoS from large response message CVSS 3.1MEDIUM 6.5
- TI-2022-13123 KubeEdge Cloud Stream and Edge Stream DoS from large stream message CVSS 3.1MEDIUM 6.5
- TI-2022-13122 KubeEdge CloudCore Router memory exhaustion CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-31077 · CVE Program
- CVE-2022-31077 · NVD
- FIRST EPSS
- GHSA-x938-fvfw-7jh5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences