Read the docs
TI-2022-13142 Aliases CVE-2022-31098GHSA-xggc-qprg-x6mw

Weave GitOps leaked cluster credentials into logs on connection errors

Priority MEDIUM 43CWE-532Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-532.

Summary

Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. A vulnerability in the logging of Weave GitOps could allow an authenticated remote attacker to view sensitive cluster configurations, aka KubeConfg, of registered Kubernetes clusters, including the service account tokens in plain text from Weave GitOps's pod logs on the management cluster. An unauthorized remote attacker can also view these sensitive configurations from external log storage if enabled by the management cluster. This vulnerability is due to the client factory dumping cluster configurations and their service account tokens when the cluster manager tries to connect to an API server of a registered cluster, and a connection error occurs. An attacker could exploit this vulnerability by either accessing logs of a pod of Weave GitOps, or from external log storage and obtaining all cluster configurations of registered clusters. A successful exploit could allow the attacker to use those cluster configurations to manage the registered Kubernetes clusters. This vulnerability has been fixed by commit 567356f471353fb5c676c77f5abc2a04631d50ca. Users should upgrade to Weave GitOps core version v0.8.1-rc.6 or newer. There is no known workaround for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01261 69th percentileScored 2026-11-07
Fix Fixed weave-gitops (weaveworks): 0.8.1-rc.6github.com/weaveworks/weave-gitops (Go): 0.8.1-rc.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
weaveworksweave-gitopsbefore 0.8.1-rc.60.8.1-rc.6Patch availableCNA
—github.com/weaveworks/weave-gitops (Go)before 0.8.1-rc.60.8.1-rc.6Patch availableGHSA-xggc-qprg-x6mw
  • weave-gitops Vendorweaveworks Affected before 0.8.1-rc.6 Fixed in 0.8.1-rc.6 Patch available CNA
  • github.com/weaveworks/weave-gitops (Go) Vendor— Affected before 0.8.1-rc.6 Fixed in 0.8.1-rc.6 Patch available GHSA-xggc-qprg-x6mw

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:weave:weave_gitops:*:*:*:*:*:*:*:*before 0.8.1VulnerableWeave
cpe:2.3:a:weave:weave_gitops:0.8.1:rc1:*:*:*:*:*:*0.8.1 rc1VulnerableWeave
cpe:2.3:a:weave:weave_gitops:0.8.1:rc2:*:*:*:*:*:*0.8.1 rc2VulnerableWeave
cpe:2.3:a:weave:weave_gitops:0.8.1:rc3:*:*:*:*:*:*0.8.1 rc3VulnerableWeave
cpe:2.3:a:weave:weave_gitops:0.8.1:rc4:*:*:*:*:*:*0.8.1 rc4VulnerableWeave
cpe:2.3:a:weave:weave_gitops:0.8.1:rc5:*:*:*:*:*:*0.8.1 rc5VulnerableWeave
  • cpe:2.3:a:weave:weave_gitops:*:*:*:*:*:*:*:* Versions before 0.8.1 Vulnerable ·Weave
  • cpe:2.3:a:weave:weave_gitops:0.8.1:rc1:*:*:*:*:*:* Versions 0.8.1 rc1 Vulnerable ·Weave
  • cpe:2.3:a:weave:weave_gitops:0.8.1:rc2:*:*:*:*:*:* Versions 0.8.1 rc2 Vulnerable ·Weave
  • cpe:2.3:a:weave:weave_gitops:0.8.1:rc3:*:*:*:*:*:* Versions 0.8.1 rc3 Vulnerable ·Weave
  • cpe:2.3:a:weave:weave_gitops:0.8.1:rc4:*:*:*:*:*:* Versions 0.8.1 rc4 Vulnerable ·Weave
  • cpe:2.3:a:weave:weave_gitops:0.8.1:rc5:*:*:*:*:*:* Versions 0.8.1 rc5 Vulnerable ·Weave

Remediation

  • Fix · CNA weave-gitops (weaveworks) Fixed in 0.8.1-rc.6
  • Fix · GHSA-xggc-qprg-x6mw github.com/weaveworks/weave-gitops (Go) Fixed in 0.8.1-rc.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31098
  2. 2026-10-03 Alias added: GHSA-xggc-qprg-x6mw

References

  • TI-2022-16400 Improper object validation allows for arbitrary code execution in GitOps Tools Extension for VSCode CVSS 3.1CRITICAL 9.8
  • TI-2022-16401 Improper KubeConfig handling allows arbitrary code execution CVSS 3.1CRITICAL 9.8
  • TI-2022-07567 GitOps Run allows for Kubernetes workload injection CVSS 3.1HIGH 8.9
  • TI-2023-17072 Information Disclosure Vulnerability in Weave GitOps Terraform Controller CVSS 3.1HIGH 8.5
  • TI-2020-16099 Weave Net Pods running in host PID namespace can be used to escalate other Kubernetes vulnerabilities CVSS 3.1HIGH 8.0
  • TI-2022-07568 Weave Gitops Run vulnerable to insecure communication CVSS 3.1HIGH 7.4
See all 8 →

Sources