Argo CD's certificate verification is skipped for connections to OIDC providers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Argo CD starting with version 0.4.0 and prior to 2.2.11, 2.3.6, and 2.4.5 is vulnerable to an improper certificate validation bug which could cause Argo CD to trust a malicious (or otherwise untrustworthy) OpenID Connect (OIDC) provider. A patch for this vulnerability has been released in Argo CD versions 2.4.5, 2.3.6, and 2.2.11. There are no complete workarounds, but a partial workaround is available. Those who use an external OIDC provider (not the bundled Dex instance), can mitigate the issue by setting the `oidc.config.rootCA` field in the `argocd-cm` ConfigMap. This mitigation only forces certificate validation when the API server handles login flows. It does not force certificate verification when verifying tokens on API calls.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| argoproj | argo-cd | 0.4.0 to before 2.2.11; 2.3.0 to before 2.3.6; 2.4.0 to before 2.4.5 | 2.2.11, 2.3.6, 2.4.5 | Patch available | CNA |
| — | github.com/argoproj/argo-cd (Go) | 0.4.0 to before 2.2.11 | 2.2.11 | Patch available | GHSA-7943-82jg-wmw5 |
| — | github.com/argoproj/argo-cd (Go) | 2.3.0 to before 2.3.6 | 2.3.6 | Patch available | GHSA-7943-82jg-wmw5 |
| — | github.com/argoproj/argo-cd (Go) | 2.4.0 to before 2.4.5 | 2.4.5 | Patch available | GHSA-7943-82jg-wmw5 |
- argo-cd Vendorargoproj Affected 0.4.0 to before 2.2.11; 2.3.0 to before 2.3.6; 2.4.0 to before 2.4.5 Fixed in 2.2.11, 2.3.6, 2.4.5 Patch available CNA
- github.com/argoproj/argo-cd (Go) Vendor— Affected 0.4.0 to before 2.2.11 Fixed in 2.2.11 Patch available GHSA-7943-82jg-wmw5
- github.com/argoproj/argo-cd (Go) Vendor— Affected 2.3.0 to before 2.3.6 Fixed in 2.3.6 Patch available GHSA-7943-82jg-wmw5
- github.com/argoproj/argo-cd (Go) Vendor— Affected 2.4.0 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-7943-82jg-wmw5
Remediation
- Fix · CNA argo-cd (argoproj) Fixed in 2.2.11, 2.3.6, 2.4.5
- Fix · GHSA-7943-82jg-wmw5 github.com/argoproj/argo-cd (Go) Fixed in 2.2.11 Advisory →
- Fix · GHSA-7943-82jg-wmw5 github.com/argoproj/argo-cd (Go) Fixed in 2.3.6 Advisory →
- Fix · GHSA-7943-82jg-wmw5 github.com/argoproj/argo-cd (Go) Fixed in 2.4.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat OpenShift GitOps
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31105
- 2026-10-03 Alias added: GHSA-7943-82jg-wmw5
References
More argoproj Argo Cd vulnerabilities
- TI-2024-14377 Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss CVSS 3.1CRITICAL 9.8
- TI-2024-14383 Argo CD vulnerable to Bypassing of Rate Limit and Brute Force Protection Using Cache Overflow CVSS 3.1CRITICAL 9.1
- TI-2026-31086 ArgoCD ServerSideDiff is vulnerable to Kubernetes Secret Extraction CVSS 3.1CRITICAL 9.6
- TI-2023-20919 Cluster secret might leak in cluster details page in Argo CD CVSS 3.1CRITICAL 9.9
- TI-2024-21088 ArgoCD Vulnerable to Use of Risky or Missing Cryptographic Algorithms in Redis Cache CVSS 3.1CRITICAL 9.1
- TI-2026-33475 Argo CD: Stored XSS in application link annotations enables developer-to-admin privilege escalation CVSS 3.1HIGH 8.7
Sources
- CVE-2022-31105 · CVE Program
- CVE-2022-31105 · NVD
- FIRST EPSS
- GHSA-7943-82jg-wmw5 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-31105 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences