Read the docs
TI-2022-13169 Aliases CVE-2022-31125

Authentication Bypass in Roxy-wi

Priority HIGH 68CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.

Summary

Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to bypass authentication and access admin functionality by sending a specially crafted HTTP request. This affects Roxywi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.20338 97th percentileScored 2026-11-07
Fix Fixed roxy-wi (hap-wi): 6.1.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
roxy-wiroxy-wibefore 6.1.1.06.1.1.0Patch availableCNA
  • roxy-wi Vendorroxy-wi Affected before 6.1.1.0 Fixed in 6.1.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:roxy-wi:roxy-wi:*:*:*:*:*:*:*:*before 6.1.1.0Vulnerableroxy-wi
  • cpe:2.3:a:roxy-wi:roxy-wi:*:*:*:*:*:*:*:* Versions before 6.1.1.0 Vulnerable ·roxy-wi

Remediation

  • Fix · CNA roxy-wi (hap-wi) Fixed in 6.1.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31125

References

  • TI-2022-13181 Unauthenticated Remote Code Execution in Roxy-WI CVSS 3.1CRITICAL 10.0
  • TI-2022-13170 Unauthenticated Remote Code Execution in Roxy-wi CVSS 3.1CRITICAL 10.0
  • TI-2026-25520 Roxy-WI has SQL Injection in haproxy_section_save Endpoint via Unsanitized server_ip Parameter CVSS 4.0HIGH 8.9
  • TI-2026-25518 Roxy-WI vulnerable to path traversal and arbitrary file writing CVSS 4.0HIGH 8.9
  • TI-2026-25519 Roxy-WI has an arbitrary file read vulnerability CVSS 4.0HIGH 7.7
  • TI-2026-22164 Roxy-WI has a Command Injection via diff parameter in config comparison allows authenticated RCE CVSS 3.1HIGH 8.8
See all 19 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences