No security checking for UnsafeAccess.getInstance() in UnsafeAccessor
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-863.
Summary
UnsafeAccessor (UA) is a bridge to access jdk.internal.misc.Unsafe & sun.misc.Unsafe. Normally, if UA is loaded as a named module, the internal data of UA is protected by JVM and others can only access UA via UA's standard API. The main application can set up `SecurityCheck.AccessLimiter` for UA to limit access to UA. Starting with version 1.4.0 and prior to version 1.7.0, when `SecurityCheck.AccessLimiter` is set up, untrusted code can access UA without limitation, even when UA is loaded as a named module. This issue does not affect those for whom `SecurityCheck.AccessLimiter` is not set up. Version 1.7.0 contains a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Karlatemp | UnsafeAccessor | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | CNA |
| — | io.github.karlatemp:unsafe-accessor (Maven) | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | GHSA-cr6p-23cf-w9g9 |
- UnsafeAccessor VendorKarlatemp Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available CNA
- io.github.karlatemp:unsafe-accessor (Maven) Vendor— Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available GHSA-cr6p-23cf-w9g9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:unsafe_accessor_project:unsafe_accessor:*:*:*:*:*:*:*:* | 1.4.0 to before 1.7.0 | Vulnerable | Unsafe Accessor Project |
- cpe:2.3:a:unsafe_accessor_project:unsafe_accessor:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.7.0 Vulnerable ·Unsafe Accessor Project
Remediation
- Fix · CNA UnsafeAccessor (Karlatemp) Fixed in 1.7.0
- Fix · GHSA-cr6p-23cf-w9g9 io.github.karlatemp:unsafe-accessor (Maven) Fixed in 1.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31139
- 2026-10-03 Alias added: GHSA-cr6p-23cf-w9g9
References
Patch 2
Advisory 2
Sources
- CVE-2022-31139 · CVE Program
- CVE-2022-31139 · NVD
- FIRST EPSS
- GHSA-cr6p-23cf-w9g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences