Improper authorization in xwiki-platform
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
XWiki Platform Security Parent POM contains the security APIs for XWiki Platform, a generic wiki platform. Starting with version 5.0 and prior to 12.10.11, 13.10.1, and 13.4.6, a bug in the security cache stores rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. The problem has been patched in XWiki 12.10.11, 13.10.1, and 13.4.6. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-platform | 5.0 to before 12.10.11; 13.0 to before 13.4.6; 13.10 to before 13.10.1 | 12.10.11, 13.4.6, 13.10.1 | Patch available | CNA |
| — | org.xwiki.platform:xwiki-platform-security (Maven) | 5.0 to before 12.10.11 | 12.10.11 | Patch available | GHSA-gg53-wf5x-r3r6 |
| — | org.xwiki.platform:xwiki-platform-security (Maven) | 13.0 to before 13.4.6 | 13.4.6 | Patch available | GHSA-gg53-wf5x-r3r6 |
| — | org.xwiki.platform:xwiki-platform-security (Maven) | 13.10 to before 13.10.1 | 13.10.1 | Patch available | GHSA-gg53-wf5x-r3r6 |
- xwiki-platform VendorXWiki Affected 5.0 to before 12.10.11; 13.0 to before 13.4.6; 13.10 to before 13.10.1 Fixed in 12.10.11, 13.4.6, 13.10.1 Patch available CNA
- org.xwiki.platform:xwiki-platform-security (Maven) Vendor— Affected 5.0 to before 12.10.11 Fixed in 12.10.11 Patch available GHSA-gg53-wf5x-r3r6
- org.xwiki.platform:xwiki-platform-security (Maven) Vendor— Affected 13.0 to before 13.4.6 Fixed in 13.4.6 Patch available GHSA-gg53-wf5x-r3r6
- org.xwiki.platform:xwiki-platform-security (Maven) Vendor— Affected 13.10 to before 13.10.1 Fixed in 13.10.1 Patch available GHSA-gg53-wf5x-r3r6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* | 5.0 to before 12.10.11; 13.0 to before 13.4.6; 13.5 to before 13.10.1 | Vulnerable | XWiki |
- cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* Versions 5.0 to before 12.10.11; 13.0 to before 13.4.6; 13.5 to before 13.10.1 Vulnerable ·XWiki
Remediation
- Fix · CNA xwiki-platform (xwiki) Fixed in 12.10.11, 13.4.6, 13.10.1
- Fix · GHSA-gg53-wf5x-r3r6 org.xwiki.platform:xwiki-platform-security (Maven) Fixed in 12.10.11 Advisory →
- Fix · GHSA-gg53-wf5x-r3r6 org.xwiki.platform:xwiki-platform-security (Maven) Fixed in 13.4.6 Advisory →
- Fix · GHSA-gg53-wf5x-r3r6 org.xwiki.platform:xwiki-platform-security (Maven) Fixed in 13.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31167
- 2026-10-03 Alias added: GHSA-gg53-wf5x-r3r6
References
More Xwiki vulnerabilities
- TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
- TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
- TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
- TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
- TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
Sources
- CVE-2022-31167 · CVE Program
- CVE-2022-31167 · NVD
- FIRST EPSS
- GHSA-gg53-wf5x-r3r6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences