Juniper is vulnerable to @DOS GraphQL Nested Fragments overflow
Priority HIGH 72CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Juniper is a GraphQL server library for Rust. Affected versions of Juniper are vulnerable to uncontrolled recursion resulting in a program crash. This issue has been addressed in version 0.15.10. Users are advised to upgrade. Users unable to upgrade should limit the recursion depth manually.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01721 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed juniper (graphql-rust): 0.15.10juniper (crates.io): 0.15.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| graphql-rust | juniper | before 0.15.10 | 0.15.10 | Patch available | CNA |
| — | juniper (crates.io) | before 0.15.10 | 0.15.10 | Patch available | GHSA-4rx6-g5vg-5f3j |
- juniper Vendorgraphql-rust Affected before 0.15.10 Fixed in 0.15.10 Patch available CNA
- juniper (crates.io) Vendor— Affected before 0.15.10 Fixed in 0.15.10 Patch available GHSA-4rx6-g5vg-5f3j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:juniper_project:juniper:*:*:*:*:*:rust:*:* | before 0.15.10 | Vulnerable | Juniper Project |
- cpe:2.3:a:juniper_project:juniper:*:*:*:*:*:rust:*:* Versions before 0.15.10 Vulnerable ·Juniper Project
Remediation
- Fix · CNA juniper (graphql-rust) Fixed in 0.15.10
- Fix · GHSA-4rx6-g5vg-5f3j juniper (crates.io) Fixed in 0.15.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31173
- 2026-10-03 Alias added: GHSA-4rx6-g5vg-5f3j
References
Patch 2
Advisory 2
Sources
- CVE-2022-31173 · CVE Program
- CVE-2022-31173 · NVD
- FIRST EPSS
- GHSA-4rx6-g5vg-5f3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences