Remote code execution in prestashop
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89 and CWE-95.
Summary
PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | PrestaShop | 1.6.0.10 to before 1.7.8.7 | 1.7.8.7 | Patch available | CNA |
| — | prestashop/prestashop (Packagist) | 1.6.0.10 to before 1.7.8.7 | 1.7.8.7 | Patch available | GHSA-hrgx-p36p-89q4 |
- PrestaShop VendorPrestaShop Affected 1.6.0.10 to before 1.7.8.7 Fixed in 1.7.8.7 Patch available CNA
- prestashop/prestashop (Packagist) Vendor— Affected 1.6.0.10 to before 1.7.8.7 Fixed in 1.7.8.7 Patch available GHSA-hrgx-p36p-89q4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* | 1.6.0.10 to before 1.7.8.7 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions 1.6.0.10 to before 1.7.8.7 Vulnerable ·PrestaShop
Remediation
- Fix · CNA PrestaShop (PrestaShop) Fixed in 1.7.8.7
- Fix · GHSA-hrgx-p36p-89q4 prestashop/prestashop (Packagist) Fixed in 1.7.8.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31181
- 2026-10-03 Alias added: GHSA-hrgx-p36p-89q4
References
Advisory 3
More Prestashop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
- TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
- TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-31181 · CVE Program
- CVE-2022-31181 · NVD
- FIRST EPSS
- GHSA-hrgx-p36p-89q4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences