Read the docs
TI-2022-13287 Aliases CVE-2022-31254GHSA-hqw6-rjpx-2wf4

rmt-server-pubcloud allows to escalate from user _rmt to root

Priority HIGH 69CWE-276Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

A Incorrect Default Permissions vulnerability in rmt-server-regsharing service of SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.1; openSUSE Leap 15.3, openSUSE Leap 15.4 allows local attackers with access to the _rmt user to escalate to root. This issue affects: SUSE Linux Enterprise Server for SAP 15 rmt-server versions prior to 2.10. SUSE Linux Enterprise Server for SAP 15-SP1 rmt-server versions prior to 2.10. SUSE Manager Server 4.1 rmt-server versions prior to 2.10. openSUSE Leap 15.3 rmt-server versions prior to 2.10. openSUSE Leap 15.4 rmt-server versions prior to 2.10.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00248 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed SUSE Linux Enterprise Server for SAP 15 (SUSE): 2.10SUSE Linux Enterprise Server for SAP 15-SP1 (SUSE): 2.10+3 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
SUSESUSE Linux Enterprise Server for SAP 15rmt-server to before 2.102.10Patch availableCNA
SUSESUSE Linux Enterprise Server for SAP 15-SP1rmt-server to before 2.102.10Patch availableCNA
SUSESUSE Manager Server 4.1rmt-server to before 2.102.10Patch availableCNA
openSUSEopenSUSE Leap 15.3rmt-server to before 2.102.10Patch availableCNA
openSUSEopenSUSE Leap 15.4rmt-server to before 2.102.10Patch availableCNA
  • SUSE Linux Enterprise Server for SAP 15 VendorSUSE Affected rmt-server to before 2.10 Fixed in 2.10 Patch available CNA
  • SUSE Linux Enterprise Server for SAP 15-SP1 VendorSUSE Affected rmt-server to before 2.10 Fixed in 2.10 Patch available CNA
  • SUSE Manager Server 4.1 VendorSUSE Affected rmt-server to before 2.10 Fixed in 2.10 Patch available CNA
  • openSUSE Leap 15.3 VendoropenSUSE Affected rmt-server to before 2.10 Fixed in 2.10 Patch available CNA
  • openSUSE Leap 15.4 VendoropenSUSE Affected rmt-server to before 2.10 Fixed in 2.10 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:opensuse:rmt-server:*:*:*:*:*:*:*:*before 2.10VulnerableopenSUSE
cpe:2.3:a:suse:manager_server:4.1:*:*:*:*:*:*:*4.1Running onSUSE
cpe:2.3:o:opensuse:leap:15.3:*:*:*:*:*:*:*15.3Running onopenSUSE
cpe:2.3:o:opensuse:leap:15.4:*:*:*:*:*:*:*15.4Running onopenSUSE
cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:*:*:*15Running onSUSE
cpe:2.3:o:suse:linux_enterprise_server:15:sp1:*:*:*:*:*:*15 sp1Running onSUSE
  • cpe:2.3:a:opensuse:rmt-server:*:*:*:*:*:*:*:* Versions before 2.10 Vulnerable ·openSUSE
  • cpe:2.3:a:suse:manager_server:4.1:*:*:*:*:*:*:* Versions 4.1 Running on ·SUSE
  • cpe:2.3:o:opensuse:leap:15.3:*:*:*:*:*:*:* Versions 15.3 Running on ·openSUSE
  • cpe:2.3:o:opensuse:leap:15.4:*:*:*:*:*:*:* Versions 15.4 Running on ·openSUSE
  • cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:*:*:* Versions 15 Running on ·SUSE
  • cpe:2.3:o:suse:linux_enterprise_server:15:sp1:*:*:*:*:*:* Versions 15 sp1 Running on ·SUSE

Remediation

  • Fix · CNA SUSE Linux Enterprise Server for SAP 15 (SUSE) Fixed in 2.10
  • Fix · CNA SUSE Linux Enterprise Server for SAP 15-SP1 (SUSE) Fixed in 2.10
  • Fix · CNA SUSE Manager Server 4.1 (SUSE) Fixed in 2.10
  • Fix · CNA openSUSE Leap 15.3 (openSUSE) Fixed in 2.10
  • Fix · CNA openSUSE Leap 15.4 (openSUSE) Fixed in 2.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31254
  2. 2026-10-03 Alias added: GHSA-hqw6-rjpx-2wf4

References

  • TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
See all 1331 →

Sources