Hyperium Hyper before 0.14.19 does not allow for customization of the…
Priority HIGH 72CWE-770Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-770.
Summary
Hyperium Hyper before 0.14.19 does not allow for customization of the max_header_list_size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01076 65th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31394
- 2026-10-03 Alias added: GHSA-x477-xp89-wc9r
References
More hyperium Hyper vulnerabilities
- TI-2023-11846 An issue was discovered in hyper v0.13.7. CVSS 3.1HIGH 7.5
- TI-2020-18306 An issue was discovered in the hyper crate before 0.12.34 for Rust. CVSS 3.1CRITICAL 9.8
- TI-2021-04399 Multiple Transfer-Encoding headers misinterprets request payload CVSS 3.1HIGH 8.1
- TI-2021-12382 Integer Overflow in Chunked Transfer-Encoding CVSS 3.1CRITICAL 9.1
- TI-2021-12383 Lenient Parsing of Content-Length Header When Prefixed with Plus Sign CVSS 3.1MEDIUM 5.3
- TI-2017-13760 An issue was discovered in the hyper crate before 0.9.18 for Rust. CVSS 3.0MEDIUM 5.3
Sources
- CVE-2022-31394 · CVE Program
- CVE-2022-31394 · NVD
- FIRST EPSS
- GHSA-x477-xp89-wc9r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences