Improper Neutralization of Command Elements in Shell User Group Provider
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The optional ShellUserGroupProvider in Apache NiFi 1.10.0 to 1.16.2 and Apache NiFi Registry 0.6.0 to 1.16.2 does not neutralize arguments for group resolution commands, allowing injection of operating system commands on Linux and macOS platforms. The ShellUserGroupProvider is not included in the default configuration. Command injection requires ShellUserGroupProvider to be one of the enabled User Group Providers in the Authorizers configuration. Command injection also requires an authenticated user with elevated privileges. Apache NiFi requires an authenticated user with authorization to modify access policies in order to execute the command. Apache NiFi Registry requires an authenticated user with authorization to read user groups in order to execute the command. The resolution removes command formatting based on user-provided arguments.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | up to 1.16.2 – 1.16.2; 1.10.0 and later | — | No fix listed | CNA |
| Apache | Apache NiFi Registry | up to 1.16.2 – 1.16.2; 0.6.0 and later | — | No fix listed | CNA |
| — | org.apache.nifi.registry:nifi-registry-core (Maven) | 0.6.0 to before 1.16.3 | 1.16.3 | Patch available | GHSA-77hf-23pq-2g7c |
| — | org.apache.nifi:nifi (Maven) | 1.10.0 to before 1.16.3 | 1.16.3 | Patch available | GHSA-77hf-23pq-2g7c |
- Apache NiFi VendorApache Affected up to 1.16.2 – 1.16.2; 1.10.0 and later Fixed in — No fix listed CNA
- Apache NiFi Registry VendorApache Affected up to 1.16.2 – 1.16.2; 0.6.0 and later Fixed in — No fix listed CNA
- org.apache.nifi.registry:nifi-registry-core (Maven) Vendor— Affected 0.6.0 to before 1.16.3 Fixed in 1.16.3 Patch available GHSA-77hf-23pq-2g7c
- org.apache.nifi:nifi (Maven) Vendor— Affected 1.10.0 to before 1.16.3 Fixed in 1.16.3 Patch available GHSA-77hf-23pq-2g7c
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* | 1.10.0 – 1.16.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi_registry:*:*:*:*:*:*:*:* | 0.6.0 – 1.16.2 | Vulnerable | Apache |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
- cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 1.10.0 – 1.16.2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi_registry:*:*:*:*:*:*:*:* Versions 0.6.0 – 1.16.2 Vulnerable ·Apache
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
Remediation
- Fix · GHSA-77hf-23pq-2g7c org.apache.nifi.registry:nifi-registry-core (Maven) Fixed in 1.16.3 Advisory →
- Fix · GHSA-77hf-23pq-2g7c org.apache.nifi:nifi (Maven) Fixed in 1.16.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-33140
- 2026-10-03 Alias added: GHSA-77hf-23pq-2g7c
- 2026-10-21 EPSS moved to the 90th–95th percentile
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2022-33140 · CVE Program
- CVE-2022-33140 · NVD
- FIRST EPSS
- GHSA-77hf-23pq-2g7c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences