Cross-site scripting in Jenkins JUnit Plugin
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.
Why it matters now
EPSS 0.77515 99th percentileScored 2026-11-07
Fix Partial Jenkins JUnit Plugin (Jenkins project): 1.53.0.1org.jenkins-ci.plugins:junit (Maven): 1119.1121.vc43d0fc45561Red Hat: 2 advisoriesRed Hat: 3 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins JUnit Plugin | up to 1119.va_a_5e9068da_d7 | 1.53.0.1 | Patch available | CNA |
| — | org.jenkins-ci.plugins:junit (Maven) | before 1119.1121.vc43d0fc45561 | 1119.1121.vc43d0fc45561 | Patch available | GHSA-64mj-3p92-589v |
- Jenkins JUnit Plugin VendorJenkins Affected up to 1119.va_a_5e9068da_d7 Fixed in 1.53.0.1 Patch available CNA
- org.jenkins-ci.plugins:junit (Maven) Vendor— Affected before 1119.1121.vc43d0fc45561 Fixed in 1119.1121.vc43d0fc45561 Patch available GHSA-64mj-3p92-589v
Remediation
- Fix · CNA Jenkins JUnit Plugin (Jenkins project) Fixed in 1.53.0.1
- Fix · GHSA-64mj-3p92-589v org.jenkins-ci.plugins:junit (Maven) Fixed in 1119.1121.vc43d0fc45561 Advisory →
Red Hat 2 advisories
- RHSA-2023:0017 Released 2023-01-12 · Red Hat rating ImportantOpenShift Container Platform 4.8.56 packages and security update
- Red Hat OpenShift Container Platform 4.8 jenkins-2-plugins-4.8.1672842762-1.el8, jenkins-2.361.1.1672840472-1.el8
- RHSA-2022:6531 Released 2022-09-21 · Red Hat rating ImportantOpenShift Container Platform 4.10.33 packages and security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1663147786-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2022:6531 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2023:0017 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | — |
Not affected: 3 products
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34176
- 2026-10-03 Alias added: GHSA-64mj-3p92-589v
References
More Jenkins Junit vulnerabilities
- TI-2018-15716 Jenkins JUnit Plugin 1.23 and earlier processes XML external entities in files it parses… CVSS 3.0HIGH 8.3
- TI-2018-15884 A cross-site request forgery vulnerability exists in Jenkins JUnit Plugin 1.25 and… CVSS 3.0MEDIUM 6.5
- TI-2023-11033 Cross-site scripting in Jenkins JUnit Plugin CVSS 3.1MEDIUM 5.4
- TI-2022-22346 Cross-site scripting in Jenkins JUnit Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-34176 · CVE Program
- CVE-2022-34176 · NVD
- FIRST EPSS
- GHSA-64mj-3p92-589v · GitHub Advisory Database · CC BY 4.0
- CVE-2022-34176 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences