Cross-site scripting in Jenkins Nested View Plugin
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Nested View Plugin 1.20 through 1.25 (both inclusive) does not escape search parameters, resulting in a reflected cross-site scripting (XSS) vulnerability.
Why it matters now
EPSS 0.00986 62nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:nested-view (Maven): 1.26
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Nested View Plugin | 1.20 and later; up to 1.25 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:nested-view (Maven) | 1.20 to before 1.26 | 1.26 | Patch available | GHSA-h642-5h74-3x9c |
- Jenkins Nested View Plugin VendorJenkins Affected 1.20 and later; up to 1.25 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:nested-view (Maven) Vendor— Affected 1.20 to before 1.26 Fixed in 1.26 Patch available GHSA-h642-5h74-3x9c
Remediation
- Fix · GHSA-h642-5h74-3x9c org.jenkins-ci.plugins:nested-view (Maven) Fixed in 1.26 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34182
- 2026-10-03 Alias added: GHSA-h642-5h74-3x9c
References
More Jenkins Nested View vulnerabilities
- TI-2021-04760 XML external entity injection in Jenkins Nested View Plugin CVSS 3.1HIGH 7.1
Sources
- CVE-2022-34182 · CVE Program
- CVE-2022-34182 · NVD
- FIRST EPSS
- GHSA-h642-5h74-3x9c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences