Read the docs
TI-2022-15112 Aliases CVE-2022-34197GHSA-cqhr-q835-62gm

Cross-site scripting in Jenkins Sauce OnDemand Plugin

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Sauce OnDemand Plugin 1.204 and earlier does not escape the name and description of Sauce Labs Browsers parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Why it matters now

EPSS 0.00653 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:sauce-ondemand (Maven): 1.205

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Sauce OnDemand Pluginup to 1.204—No fix listedCNA
—org.jenkins-ci.plugins:sauce-ondemand (Maven)before 1.2051.205Patch availableGHSA-cqhr-q835-62gm
  • Jenkins Sauce OnDemand Plugin VendorJenkins Affected up to 1.204 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:sauce-ondemand (Maven) Vendor— Affected before 1.205 Fixed in 1.205 Patch available GHSA-cqhr-q835-62gm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:sauce_ondemand:*:*:*:*:*:jenkins:*:*up to 1.204VulnerableJenkins
  • cpe:2.3:a:jenkins:sauce_ondemand:*:*:*:*:*:jenkins:*:* Versions up to 1.204 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-cqhr-q835-62gm org.jenkins-ci.plugins:sauce-ondemand (Maven) Fixed in 1.205 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-34197
  2. 2026-10-03 Alias added: GHSA-cqhr-q835-62gm
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

Sources