Read the docs
TI-2022-15232 Aliases CVE-2022-34321GHSA-c35h-w8hj-mm55

Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint

Priority MEDIUM 45CWE-306Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · Low
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-306.

Summary

Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials. This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0. The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer's default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to "Cluster" by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren't known to be exposed. 2.10 Pulsar Proxy users should upgrade to at least 2.10.6. 2.11 Pulsar Proxy users should upgrade to at least 2.11.3. 3.0 Pulsar Proxy users should upgrade to at least 3.0.2. 3.1 Pulsar Proxy users should upgrade to at least 3.1.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it's imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01765 78th percentileScored 2026-11-07
Fix Partial Apache Pulsar (Apache Software Foundation): 2.10.6, 2.11.3, 3.0.2 +1org.apache.pulsar:pulsar-proxy (Maven): 2.10.6, 2.11.3, 3.0.2 +1Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Pulsar2.6.0 to before 2.10.6; 2.11.0 to before 2.11.3; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.12.10.6, 2.11.3, 3.0.2, 3.1.1Patch availableCNA
—org.apache.pulsar:pulsar-proxy (Maven)2.6.0 to before 2.10.62.10.6Patch availableGHSA-c35h-w8hj-mm55
—org.apache.pulsar:pulsar-proxy (Maven)2.11.0 to before 2.11.32.11.3Patch availableGHSA-c35h-w8hj-mm55
—org.apache.pulsar:pulsar-proxy (Maven)3.0.0 to before 3.0.23.0.2Patch availableGHSA-c35h-w8hj-mm55
—org.apache.pulsar:pulsar-proxy (Maven)3.1.0 to before 3.1.13.1.1Patch availableGHSA-c35h-w8hj-mm55
  • Apache Pulsar VendorApache Affected 2.6.0 to before 2.10.6; 2.11.0 to before 2.11.3; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.1 Fixed in 2.10.6, 2.11.3, 3.0.2, 3.1.1 Patch available CNA
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 2.6.0 to before 2.10.6 Fixed in 2.10.6 Patch available GHSA-c35h-w8hj-mm55
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 2.11.0 to before 2.11.3 Fixed in 2.11.3 Patch available GHSA-c35h-w8hj-mm55
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-c35h-w8hj-mm55
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-c35h-w8hj-mm55

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*2.6.0 to before 2.10.6; 2.11.0 to before 2.11.3; 3.0.0 to before 3.0.2VulnerableApache
cpe:2.3:a:apache:pulsar:3.1.0:-:*:*:*:*:*:*3.1.0VulnerableApache
  • cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* Versions 2.6.0 to before 2.10.6; 2.11.0 to before 2.11.3; 3.0.0 to before 3.0.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:pulsar:3.1.0:-:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Pulsar (Apache Software Foundation) Fixed in 2.10.6, 2.11.3, 3.0.2, 3.1.1
  • Fix · GHSA-c35h-w8hj-mm55 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.10.6 Advisory →
  • Fix · GHSA-c35h-w8hj-mm55 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.11.3 Advisory →
  • Fix · GHSA-c35h-w8hj-mm55 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 3.0.2 Advisory →
  • Fix · GHSA-c35h-w8hj-mm55 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 3.1.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Fuse 7AffectedNo fix yet
Not affected: 4 products
  • Red Hat Integration Camel K 1
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat build of Apache Camel for Spring Boot 3
  • Red Hat build of Apache Camel for Spring Boot 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-34321
  2. 2026-10-03 Alias added: GHSA-c35h-w8hj-mm55

References

  • TI-2024-18155 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification CVSS 3.1CRITICAL 9.9
  • TI-2021-05150 Authentication with JWT allows use of “none”-algorithm CVSS 3.1CRITICAL 9.8
  • TI-2024-17990 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution CVSS 3.1CRITICAL 9.9
  • TI-2023-14272 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy CVSS 3.1CRITICAL 9.6
  • TI-2024-18500 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying CVSS 3.1HIGH 8.8
  • TI-2023-19177 Apache Pulsar Function Worker: Incorrect Authorization for Function Worker Can Leak Sink/Source Credentials CVSS 3.1HIGH 8.2
See all 19 →

Sources