Improper authorization in Dell Cloud Mobility for Dell Storage
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
Cloud Mobility for Dell Storage versions 1.3.0 and earlier contains an Improper Access Control vulnerability within the Postgres database. A threat actor with root level access to either the vApp or containerized versions of Cloud Mobility may potentially exploit this vulnerability, leading to the modification or deletion of tables that are required for many of the core functionalities of Cloud Mobility. Exploitation may lead to the compromise of integrity and availability of the normal functionality of the Cloud Mobility application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Cloud Mobility for Dell Storage (Dell) Fixed in 1.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34434
- 2026-10-03 Alias added: GHSA-3j7r-r9wv-qrjp
References
More Dell Cloud Mobility For Dell Emc Storage vulnerabilities
- TI-2022-14940 Cloud Mobility for Dell EMC Storage, 1.3.0.XXX contains a RCE vulnerability. CVSS 3.1CRITICAL 9.8
- TI-2023-09504 Improper certificate validation in Dell Cloud Mobility for Dell Storage CVSS 3.1HIGH 7.0
Sources
- CVE-2022-34434 · CVE Program
- CVE-2022-34434 · NVD
- FIRST EPSS
- GHSA-3j7r-r9wv-qrjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences