Exposure of resource to wrong sphere in Siemens SICAM GridEdge
Priority LOW 24CWE-552Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-552.
Summary
A vulnerability has been identified in SICAM GridEdge (Classic) (All versions < V2.7.3). The affected application uses an improperly protected file to import SSH keys. This could allow attackers with access to the filesystem of the host on which SICAM GridEdge runs to inject a custom SSH key to that file.
Why it matters now
EPSS 0.0044 38th percentileScored 2026-11-07
Fix Fixed SICAM GridEdge (Classic) (Siemens): V2.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Siemens | SICAM GridEdge (Classic) | before V2.7.3 | V2.7.3 | Patch available | CNA |
- SICAM GridEdge (Classic) VendorSiemens Affected before V2.7.3 Fixed in V2.7.3 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:siemens:sicam_gridedge_essential_arm:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Siemens |
| cpe:2.3:a:siemens:sicam_gridedge_essential_gds_arm:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Siemens |
| cpe:2.3:a:siemens:sicam_gridedge_essential_gds_intel:*:*:*:*:*:*:*:* | before 2.7.3 | Vulnerable | Siemens |
| cpe:2.3:a:siemens:sicam_gridedge_essential_intel:*:*:*:*:*:*:*:* | before 2.7.3 | Vulnerable | Siemens |
- cpe:2.3:a:siemens:sicam_gridedge_essential_arm:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Siemens
- cpe:2.3:a:siemens:sicam_gridedge_essential_gds_arm:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Siemens
- cpe:2.3:a:siemens:sicam_gridedge_essential_gds_intel:*:*:*:*:*:*:*:* Versions before 2.7.3 Vulnerable ·Siemens
- cpe:2.3:a:siemens:sicam_gridedge_essential_intel:*:*:*:*:*:*:*:* Versions before 2.7.3 Vulnerable ·Siemens
Remediation
- Fix · CNA SICAM GridEdge (Classic) (Siemens) Fixed in V2.7.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34464
- 2026-10-03 Alias added: GHSA-xp6h-v5w9-gwqx
References
Sources
- CVE-2022-34464 · CVE Program
- CVE-2022-34464 · NVD
- FIRST EPSS
- GHSA-xp6h-v5w9-gwqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences