WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr 2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and…
Priority MEDIUM 45Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr 2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and global-workqueue 1.4.1rc5 allows attackers to execute arbitrary code via a crafted dbs-client package.
Why it matters now
EPSS 0.01299 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed wmagent (PyPI): 2.0.4reqmgr2 (PyPI): 2.0.4+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | wmagent (PyPI) | 1.3.3rc1 to before 2.0.4 | 2.0.4 | Patch available | GHSA-4vq7-8699-4xgc |
| — | reqmgr2 (PyPI) | 1.4.0rc2 to before 2.0.4 | 2.0.4 | Patch available | GHSA-4vq7-8699-4xgc |
| — | reqmon (PyPI) | 1.4.1rc5 to before 2.0.4 | 2.0.4 | Patch available | GHSA-4vq7-8699-4xgc |
| — | global-workqueue (PyPI) | 1.4.1rc5 to before 2.0.4 | 2.0.4 | Patch available | GHSA-4vq7-8699-4xgc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- wmagent (PyPI) Vendor— Affected 1.3.3rc1 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4vq7-8699-4xgc
- reqmgr2 (PyPI) Vendor— Affected 1.4.0rc2 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4vq7-8699-4xgc
- reqmon (PyPI) Vendor— Affected 1.4.1rc5 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4vq7-8699-4xgc
- global-workqueue (PyPI) Vendor— Affected 1.4.1rc5 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4vq7-8699-4xgc
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:global-workqueue_project:global-workqueue:1.4.1:rc5:*:*:*:python:*:* | 1.4.1 rc5 | Vulnerable | Global-workqueue Project |
| cpe:2.3:a:reqmgr2_project:reqmgr2:1.4.0:rc2:*:*:*:python:*:* | 1.4.0 rc2 | Vulnerable | Reqmgr2 Project |
| cpe:2.3:a:reqmgr2_project:reqmgr2:1.4.1:rc5:*:*:*:python:*:* | 1.4.1 rc5 | Vulnerable | Reqmgr2 Project |
| cpe:2.3:a:reqmon_project:reqmon:1.4.1:rc5:*:*:*:python:*:* | 1.4.1 rc5 | Vulnerable | Reqmon Project |
| cpe:2.3:a:wmagent_project:wmagent:1.3.3:rc1:*:*:*:python:*:* | 1.3.3 rc1 | Vulnerable | Wmagent Project |
| cpe:2.3:a:wmagent_project:wmagent:1.3.3:rc2:*:*:*:python:*:* | 1.3.3 rc2 | Vulnerable | Wmagent Project |
- cpe:2.3:a:global-workqueue_project:global-workqueue:1.4.1:rc5:*:*:*:python:*:* Versions 1.4.1 rc5 Vulnerable ·Global-workqueue Project
- cpe:2.3:a:reqmgr2_project:reqmgr2:1.4.0:rc2:*:*:*:python:*:* Versions 1.4.0 rc2 Vulnerable ·Reqmgr2 Project
- cpe:2.3:a:reqmgr2_project:reqmgr2:1.4.1:rc5:*:*:*:python:*:* Versions 1.4.1 rc5 Vulnerable ·Reqmgr2 Project
- cpe:2.3:a:reqmon_project:reqmon:1.4.1:rc5:*:*:*:python:*:* Versions 1.4.1 rc5 Vulnerable ·Reqmon Project
- cpe:2.3:a:wmagent_project:wmagent:1.3.3:rc1:*:*:*:python:*:* Versions 1.3.3 rc1 Vulnerable ·Wmagent Project
- cpe:2.3:a:wmagent_project:wmagent:1.3.3:rc2:*:*:*:python:*:* Versions 1.3.3 rc2 Vulnerable ·Wmagent Project
Remediation
- Fix · GHSA-4vq7-8699-4xgc wmagent (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-4vq7-8699-4xgc reqmgr2 (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-4vq7-8699-4xgc reqmon (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-4vq7-8699-4xgc global-workqueue (PyPI) Fixed in 2.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34558
- 2026-10-03 Alias added: GHSA-4vq7-8699-4xgc
References
Other 4
Sources
- CVE-2022-34558 · CVE Program
- CVE-2022-34558 · NVD
- FIRST EPSS
- GHSA-4vq7-8699-4xgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences