An insufficient entropy vulnerability caused by the improper use of randomness sources…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An insufficient entropy vulnerability caused by the improper use of randomness sources with low entropy for RSA key pair generation was found in Zyxel GS1900 series firmware versions prior to V2.70. This vulnerability could allow an unauthenticated attacker to retrieve a private key by factoring the RSA modulus N in the certificate of the web administration interface.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zyxel | Zyxel GS1900 series firmware | before V2.70 | V2.70 | Patch available | CNA |
- Zyxel GS1900 series firmware VendorZyxel Affected before V2.70 Fixed in V2.70 Patch available CNA
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:zyxel:gs1900-8_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahh.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-8:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-8hp_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahi.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-8hp:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-10hp_firmware:*:*:*:*:*:*:*:* | before 2.70\(aazi.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-10hp:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-16_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahj.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-16:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-24_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahl.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-24:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
- cpe:2.3:o:zyxel:gs1900-8_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahh.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-8:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-8hp_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahi.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-8hp:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-10hp_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aazi.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-10hp:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-16_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahj.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-16:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-24_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahl.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-24:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:zyxel:gs1900-24e_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahk.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-24e:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-24ep_firmware:*:*:*:*:*:*:*:* | before 2.70\(abto.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-24ep:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-24hpv2_firmware:*:*:*:*:*:*:*:* | before 2.70\(abtp.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-24hpv2:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-48_firmware:*:*:*:*:*:*:*:* | before 2.70\(aahn.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-48:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
| cpe:2.3:o:zyxel:gs1900-48hpv2_firmware:*:*:*:*:*:*:*:* | before 2.70\(abtq.3\)c0 | Vulnerable | Zyxel |
| cpe:2.3:h:zyxel:gs1900-48hpv2:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Zyxel |
- cpe:2.3:o:zyxel:gs1900-24e_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahk.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-24e:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-24ep_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(abto.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-24ep:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-24hpv2_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(abtp.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-24hpv2:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-48_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(aahn.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-48:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
- cpe:2.3:o:zyxel:gs1900-48hpv2_firmware:*:*:*:*:*:*:*:* Versions before 2.70\(abtq.3\)c0 Vulnerable ·Zyxel
- cpe:2.3:h:zyxel:gs1900-48hpv2:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Zyxel
Remediation
- Fix · CNA Zyxel GS1900 series firmware (Zyxel) Fixed in V2.70
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34746
- 2026-10-03 Alias added: GHSA-cqpc-c229-h8hr
References
More Zyxel Gs1900-10hp Firmware vulnerabilities
- TI-2026-06387 Stack-based buffer overflow in Zyxel GS1900-48HPv2 firmware KEVCVSS 3.1HIGH 8.8
- TI-2019-11869 An issue was discovered on Zyxel GS1900 devices with firmware before 2.50(AAHH.0)C0. CVSS 3.1CRITICAL 9.8
- TI-2016-01221 Cisco NX-OS 6.0(2)U6(1) through 6.0(2)U6(5) on Nexus 3000 devices and 6.0(2)A6(1) through… CVSS 3.0CRITICAL 9.8
- TI-2015-05062 Belkin F9K1102 2 devices with firmware 2.10.17 rely on client-side JavaScript code for… CVSS 3.0CRITICAL 9.8
- TI-2015-05061 The web management interface on Belkin F9K1102 2 devices with firmware 2.10.17 has a… CVSS 3.0CRITICAL 9.8
- TI-2019-11872 An issue was discovered on Zyxel GS1900 devices with firmware before 2.50(AAHH.0)C0. CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-34746 · CVE Program
- CVE-2022-34746 · NVD
- FIRST EPSS
- GHSA-cqpc-c229-h8hr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences