An issue in Renato v0.17.0 allows attackers to cause a Denial of Service (DoS) via a…
Priority LOW 36CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
An issue in Renato v0.17.0 allows attackers to cause a Denial of Service (DoS) via a crafted payload injected into the Search parameter.
Why it matters now
EPSS 0.01592 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed raneto (npm): 0.17.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | raneto (npm) | before 0.17.1 | 0.17.1 | Patch available | GHSA-xxc2-j7jj-6g5m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- raneto (npm) Vendor— Affected before 0.17.1 Fixed in 0.17.1 Patch available GHSA-xxc2-j7jj-6g5m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:raneto_project:raneto:*:*:*:*:*:node.js:*:* | before 0.17.1 | Vulnerable | Raneto Project |
- cpe:2.3:a:raneto_project:raneto:*:*:*:*:*:node.js:*:* Versions before 0.17.1 Vulnerable ·Raneto Project
Remediation
- Fix · GHSA-xxc2-j7jj-6g5m raneto (npm) Fixed in 0.17.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35142
- 2026-10-03 Alias added: GHSA-xxc2-j7jj-6g5m
References
Advisory 3
More Raneto Project Raneto vulnerabilities
- TI-2022-15859 Renato v0.17.0 employs weak password complexity requirements, allowing attackers to crack… CVSS 3.1CRITICAL 9.8
- TI-2022-15860 Renato v0.17.0 was discovered to contain a cross-site scripting (XSS) vulnerability. CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-35142 · CVE Program
- CVE-2022-35142 · NVD
- FIRST EPSS
- GHSA-xxc2-j7jj-6g5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences