AEM File Upload Security Issue leading to RXSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Adobe Experience Manager Core Components version 2.20.6 (and earlier) is affected by a reflected Cross-Site Scripting (XSS) vulnerability. If an attacker is able to convince a victim to visit a URL referencing a vulnerable page, malicious JavaScript content may be executed within the context of the victim's browser. Exploitation of this issue requires a low author privilege access.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Experience Manager | up to 2.20.6; up to None | — | No fix listed | CNA |
| — | com.adobe.cq:core.wcm.components.core (Maven) | before 2.20.8 | 2.20.8 | Patch available | GHSA-qcgc-6q86-7x2p |
- Experience Manager VendorAdobe Affected up to 2.20.6; up to None Fixed in — No fix listed CNA
- com.adobe.cq:core.wcm.components.core (Maven) Vendor— Affected before 2.20.8 Fixed in 2.20.8 Patch available GHSA-qcgc-6q86-7x2p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:web_content_management_core_components:*:*:*:*:*:adobe_experience_manager:*:* | up to 2.20.6 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:web_content_management_core_components:*:*:*:*:*:adobe_experience_manager:*:* Versions up to 2.20.6 Vulnerable ·Adobe
Remediation
- Fix · GHSA-qcgc-6q86-7x2p com.adobe.cq:core.wcm.components.core (Maven) Fixed in 2.20.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35697
- 2026-10-03 Alias added: GHSA-qcgc-6q86-7x2p
References
Sources
- CVE-2022-35697 · CVE Program
- CVE-2022-35697 · NVD
- FIRST EPSS
- GHSA-qcgc-6q86-7x2p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences