dotCMS before 22.06 allows remote attackers to bypass intended access control and obtain…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
dotCMS before 22.06 allows remote attackers to bypass intended access control and obtain sensitive information by using a semicolon in a URL to introduce a matrix parameter. (This is also fixed in 5.3.8.12, 21.06.9, and 22.03.2 for LTS users.) Some Java application frameworks, including those used by Spring or Tomcat, allow the use of matrix parameters: these are URI parameters separated by semicolons. Through precise semicolon placement in a URI, it is possible to exploit this feature to avoid dotCMS's path-based XSS prevention (such as "require login" filters), and consequently access restricted resources. For example, an attacker could place a semicolon immediately before a / character that separates elements of a filesystem path. This could reveal file content that is ordinarily only visible to signed-in users. This issue can be chained with other exploit code to achieve XSS attacks against dotCMS.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dotcms:dotcms:*:*:*:*:lts:*:*:* | 5.3.8 to before 5.3.8.12; 21.06 to before 21.06.9 | Vulnerable | dotCMS |
| cpe:2.3:a:dotcms:dotcms:*:*:*:*:*:*:*:* | 22.01 to before 22.06 | Vulnerable | dotCMS |
| cpe:2.3:a:dotcms:dotcms:*:*:*:*:lts:*:*:* | 22.03 to before 22.03.2 | Vulnerable | dotCMS |
- cpe:2.3:a:dotcms:dotcms:*:*:*:*:lts:*:*:* Versions 5.3.8 to before 5.3.8.12; 21.06 to before 21.06.9 Vulnerable ·dotCMS
- cpe:2.3:a:dotcms:dotcms:*:*:*:*:*:*:*:* Versions 22.01 to before 22.06 Vulnerable ·dotCMS
- cpe:2.3:a:dotcms:dotcms:*:*:*:*:lts:*:*:* Versions 22.03 to before 22.03.2 Vulnerable ·dotCMS
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35740
- 2026-10-03 Alias added: GHSA-qv8m-37rr-fj54
References
More Dotcms vulnerabilities
- TI-2022-09726 An issue was discovered in the ContentResource API in dotCMS 3.0 through 22.02. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05479 dotCMS before 5.2.4 is vulnerable to directory traversal, leading to incorrect access… CVSS 3.1CRITICAL 9.8
- TI-2020-13533 Unrestricted Upload of File with Dangerous Type in DotCMS v5.2.3 and earlier allow remote… CVSS 3.1CRITICAL 9.8
- TI-2017-03385 An issue was discovered in dotCMS through 3.6.1. CVSS 3.0CRITICAL 9.8
- TI-2016-07300 SQL injection vulnerability in the categoriesServlet servlet in dotCMS before 3.3.1… CVSS 3.0CRITICAL 9.8
- TI-2016-02117 SQL injection vulnerability in the REST API in dotCMS before 3.3.2 allows remote… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2022-35740 · CVE Program
- CVE-2022-35740 · NVD
- FIRST EPSS
- GHSA-qv8m-37rr-fj54 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences