Out-of-bounds read in IPv6 neighbor solicitation in Contiki-NG
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-125 and the CVSS impact.
Summary
Contiki-NG is an open-source, cross-platform operating system for IoT devices. Because of insufficient validation of IPv6 neighbor discovery options in Contiki-NG, attackers can send neighbor solicitation packets that trigger an out-of-bounds read. The problem exists in the module os/net/ipv6/uip-nd6.c, where memory read operations from the main packet buffer, <code>uip_buf</code>, are not checked if they go out of bounds. In particular, this problem can occur when attempting to read the 2-byte option header and the Source Link-Layer Address Option (SLLAO). This attack requires ipv6 be enabled for the network. The problem has been patched in the develop branch of Contiki-NG. The upcoming 4.8 release of Contiki-NG will include the patch.Users unable to upgrade may apply the patch in Contiki-NG PR #1654.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contiki-ng | contiki-ng | before 4.8 | 4.8 | Patch available | CNA |
- contiki-ng Vendorcontiki-ng Affected before 4.8 Fixed in 4.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:contiki-ng:contiki-ng:*:*:*:*:*:*:*:* | before 4.8 | Vulnerable | contiki-ng |
- cpe:2.3:o:contiki-ng:contiki-ng:*:*:*:*:*:*:*:* Versions before 4.8 Vulnerable ·contiki-ng
Remediation
- Fix · CNA contiki-ng (contiki-ng) Fixed in 4.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35926
References
Patch 2
More Contiki-ng vulnerabilities
- TI-2020-14885 An issue was discovered in Contiki through 3.0 and Contiki-NG through 4.5. CVSS 3.1CRITICAL 9.8
- TI-2020-16751 In Contiki 4.5, TCP ISNs are improperly random. CVSS 3.1CRITICAL 9.1
- TI-2018-16029 contiki-ng version 4 contains a Buffer Overflow vulnerability in AQL (Antelope Query… CVSS 3.1CRITICAL 9.8
- TI-2018-13749 An issue was discovered in the MQTT server in Contiki-NG before 4.2. CVSS 3.0CRITICAL 10.0
- TI-2023-14381 Contiki-NG has off-by-one error in Antelope DBMS CVSS 3.1CRITICAL 9.8
- TI-2023-14839 Contiki-NG missing NULL pointer check in IPv6 neighbor discovery CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences