loopback-connector-postgresql Vulnerable to Improper Sanitization of `contains` Filter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Improper input validation on the `contains` LoopBack filter may allow for arbitrary SQL injection. When the extended filter property `contains` is permitted to be interpreted by the Postgres connector, it is possible to inject arbitrary SQL which may affect the confidentiality and integrity of data stored on the connected database. A patch was released in version 5.5.1. This affects users who does any of the following: - Connect to the database via the DataSource with `allowExtendedProperties: true` setting OR - Uses the connector's CRUD methods directly OR - Uses the connector's other methods to interpret the LoopBack filter. Users who are unable to upgrade should do the following if applicable: - Remove `allowExtendedProperties: true` DataSource setting - Add `allowExtendedProperties: false` DataSource setting - When passing directly to the connector functions, manually sanitize the user input for the `contains` LoopBack filter beforehand.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| loopbackio | loopback-connector-postgresql | before 5.5.1 | 5.5.1 | Patch available | CNA |
| — | loopback-connector-postgresql (npm) | before 5.5.1 | 5.5.1 | Patch available | GHSA-j259-6c58-9m58 |
- loopback-connector-postgresql Vendorloopbackio Affected before 5.5.1 Fixed in 5.5.1 Patch available CNA
- loopback-connector-postgresql (npm) Vendor— Affected before 5.5.1 Fixed in 5.5.1 Patch available GHSA-j259-6c58-9m58
Remediation
- Fix · CNA loopback-connector-postgresql (loopbackio) Fixed in 5.5.1
- Fix · GHSA-j259-6c58-9m58 loopback-connector-postgresql (npm) Fixed in 5.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35942
- 2026-10-03 Alias added: GHSA-j259-6c58-9m58
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Advisory 2
Sources
- CVE-2022-35942 · CVE Program
- CVE-2022-35942 · NVD
- FIRST EPSS
- GHSA-j259-6c58-9m58 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences