Read the docs
TI-2022-16381 Aliases CVE-2022-35954GHSA-7r3h-m5j6-3q42

Delimiter injection vulnerability in @actions/core exportVariable

Priority LOW 24CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.

Summary

The GitHub Actions ToolKit provides a set of packages to make creating actions easier. The `core.exportVariable` function uses a well known delimiter that attackers can use to break out of that specific variable and assign values to other arbitrary variables. Workflows that write untrusted values to the `GITHUB_ENV` file may cause the path or other environment variables to be modified without the intention of the workflow or action author. Users should upgrade to `@actions/core v1.9.1`. If you are unable to upgrade the `@actions/core` package, you can modify your action to ensure that any user input does not contain the delimiter `_GitHubActionsFileCommandDelimeter_` before calling `core.exportVariable`.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00704 53rd percentileScored 2026-11-07
Fix Fixed @actions/core (npm): 1.9.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
actionstoolkitup to 1.9.0—No fix listedCNA
—@actions/core (npm)before 1.9.11.9.1Patch availableGHSA-7r3h-m5j6-3q42
  • toolkit Vendoractions Affected up to 1.9.0 Fixed in — No fix listed CNA
  • @actions/core (npm) Vendor— Affected before 1.9.1 Fixed in 1.9.1 Patch available GHSA-7r3h-m5j6-3q42

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:github:toolkit:*:*:*:*:*:node.js:*:*before 1.9.1VulnerableGitHub
  • cpe:2.3:a:github:toolkit:*:*:*:*:*:node.js:*:* Versions before 1.9.1 Vulnerable ·GitHub

Remediation

  • Fix · GHSA-7r3h-m5j6-3q42 @actions/core (npm) Fixed in 1.9.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35954
  2. 2026-10-03 Alias added: GHSA-7r3h-m5j6-3q42

References

  • TI-2025-05316 actions toolkit glob internal-pattern.ts globEscape redos CVSS 4.0MEDIUM 5.3

Sources