Bots using py-cord as discord api wrapper are vulnerable to shutdowns through remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pycord-Development | pycord | = 2.0.0 | — | No fix listed | CNA |
| — | py-cord (PyPI) | 2.0.0 to before 2.0.1 | 2.0.1 | Patch available | GHSA-qmhj-m29v-gvmr |
- pycord VendorPycord-Development Affected = 2.0.0 Fixed in — No fix listed CNA
- py-cord (PyPI) Vendor— Affected 2.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available GHSA-qmhj-m29v-gvmr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pycord_development:pycord:2.0.0:*:*:*:*:discord:*:* | 2.0.0 | Vulnerable | Pycord-Development |
- cpe:2.3:a:pycord_development:pycord:2.0.0:*:*:*:*:discord:*:* Versions 2.0.0 Vulnerable ·Pycord-Development
Remediation
- Fix · GHSA-qmhj-m29v-gvmr py-cord (PyPI) Fixed in 2.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36024
- 2026-10-03 Alias added: GHSA-qmhj-m29v-gvmr
References
Advisory 2
Sources
- CVE-2022-36024 · CVE Program
- CVE-2022-36024 · NVD
- FIRST EPSS
- GHSA-qmhj-m29v-gvmr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences