Cross-site scripting (XSS) from dynamic options in the multiselect field in Kirby
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
kirby is a content management system (CMS) that adapts to many different projects and helps you build your own ideal interface. Cross-site scripting (XSS) is a type of vulnerability that allows execution of any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. If bad actors gain access to your group of authenticated Panel users they can escalate their privileges via the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. The multiselect field allows selection of tags from an autocompleted list. Unfortunately, the Panel in Kirby 3.5 used HTML rendering for the raw option value. This allowed **attackers with influence on the options source** to store HTML code. The browser of the victim who visited a page with manipulated multiselect options in the Panel will then have rendered this malicious HTML code when the victim opened the autocomplete dropdown. Users are *not* affected by this vulnerability if you don't use the multiselect field or don't use it with options that can be manipulated by attackers. The problem has been patched in Kirby 3.5.8.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 3.5.8.1 | 3.5.8.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 3.5.8.1 | 3.5.8.1 | Patch available | GHSA-3f89-869f-5w76 |
- kirby Vendorgetkirby Affected before 3.5.8.1 Fixed in 3.5.8.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 3.5.8.1 Fixed in 3.5.8.1 Patch available GHSA-3f89-869f-5w76
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.5.8.1
- Fix · GHSA-3f89-869f-5w76 getkirby/cms (Packagist) Fixed in 3.5.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36037
- 2026-10-03 Alias added: GHSA-3f89-869f-5w76
References
Patch 2
Advisory 2
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2022-36037 · CVE Program
- CVE-2022-36037 · NVD
- FIRST EPSS
- GHSA-3f89-869f-5w76 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences