Read the docs
TI-2022-16492 Aliases CVE-2022-36069GHSA-9xgj-fcgf-x6mw

Poetry Argument Injection vulnerability can lead to local Code Execution

Priority HIGH 67CWE-94Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Poetry is a dependency manager for Python. When handling dependencies that come from a Git repository instead of a registry, Poetry uses various commands, such as `git clone`. These commands are constructed using user input (e.g. the repository URL). When building the commands, Poetry correctly avoids Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. If a developer is exploited, the attacker could steal credentials or persist their access. If the exploit happens on a server, the attackers could use their access to attack other internal systems. Since this vulnerability requires a fair amount of user interaction, it is not as dangerous as a remotely exploitable one. However, it still puts developers at risk when dealing with untrusted files in a way they think is safe, because the exploit still works when the victim tries to make sure nothing can happen, e.g. by vetting any Git or Poetry config files that might be present in the directory. Versions 1.1.9 and 1.2.0b1 contain patches for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01324 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed poetry (python-poetry): 1.1.9poetry (PyPI): 1.1.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
python-poetrypoetrybefore 1.1.91.1.9Patch availableCNA
—poetry (PyPI)before 1.1.91.1.9Patch availableGHSA-9xgj-fcgf-x6mw
  • poetry Vendorpython-poetry Affected before 1.1.9 Fixed in 1.1.9 Patch available CNA
  • poetry (PyPI) Vendor— Affected before 1.1.9 Fixed in 1.1.9 Patch available GHSA-9xgj-fcgf-x6mw

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:python-poetry:poetry:*:*:*:*:*:python:*:*before 1.1.9Vulnerablepython-poetry
cpe:2.3:a:python-poetry:poetry:1.2.0:alpha1:*:*:*:python:*:*1.2.0 alpha1Vulnerablepython-poetry
cpe:2.3:a:python-poetry:poetry:1.2.0:alpha2:*:*:*:python:*:*1.2.0 alpha2Vulnerablepython-poetry
  • cpe:2.3:a:python-poetry:poetry:*:*:*:*:*:python:*:* Versions before 1.1.9 Vulnerable ·python-poetry
  • cpe:2.3:a:python-poetry:poetry:1.2.0:alpha1:*:*:*:python:*:* Versions 1.2.0 alpha1 Vulnerable ·python-poetry
  • cpe:2.3:a:python-poetry:poetry:1.2.0:alpha2:*:*:*:python:*:* Versions 1.2.0 alpha2 Vulnerable ·python-poetry

Remediation

  • Fix · CNA poetry (python-poetry) Fixed in 1.1.9
  • Fix · GHSA-9xgj-fcgf-x6mw poetry (PyPI) Fixed in 1.1.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36069
  2. 2026-10-03 Alias added: GHSA-9xgj-fcgf-x6mw

References

  • TI-2026-26838 Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write CVSS 4.0HIGH 7.1
  • TI-2022-09621 Poetry v1.1.9 and below was discovered to contain an untrusted search path which causes… CVSS 3.1CRITICAL 9.8
  • TI-2022-16493 Poetry's Untrusted Search Path can lead to Local Code Execution on Windows CVSS 3.1HIGH 7.3

Sources