Read the docs
TI-2022-16550 Aliases CVE-2022-36127GHSA-8gpg-466c-5cpj

Service unavailability impact in NodeJS agent(version <= 0.5.0)

Priority LOW 37Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

A vulnerability in Apache SkyWalking NodeJS Agent prior to 0.5.1. The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.

Why it matters now

EPSS 0.01866 79th percentileScored 2026-11-07
Fix Fixed skywalking-backend-js (npm): 0.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache SkyWalking NodeJS AgentApache SkyWalking NodeJS Agent – 0.5.0—No fix listedCNA
—skywalking-backend-js (npm)before 0.5.10.5.1Patch availableGHSA-8gpg-466c-5cpj
  • Apache SkyWalking NodeJS Agent VendorApache Affected Apache SkyWalking NodeJS Agent – 0.5.0 Fixed in — No fix listed CNA
  • skywalking-backend-js (npm) Vendor— Affected before 0.5.1 Fixed in 0.5.1 Patch available GHSA-8gpg-466c-5cpj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:skywalking_nodejs_agent:*:*:*:*:*:node.js:*:*before 0.5.1VulnerableApache
  • cpe:2.3:a:apache:skywalking_nodejs_agent:*:*:*:*:*:node.js:*:* Versions before 0.5.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-8gpg-466c-5cpj skywalking-backend-js (npm) Fixed in 0.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36127
  2. 2026-10-03 Alias added: GHSA-8gpg-466c-5cpj

References

Sources