HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-306.
Summary
HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using Integrated Storage expose an unauthenticated API endpoint that could be abused to override the voter status of a node within a Vault HA cluster, introducing potential for future data loss or catastrophic failure. Fixed in Vault Enterprise 1.9.8, 1.10.5, and 1.11.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat OpenShift Container Platform 4
- Red Hat Openshift Container Storage 4
- Red Hat Openshift Data Foundation 4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36129
- 2026-10-03 Alias added: GHSA-c8mv-ccvj-9h5q
References
More HashiCorp Vault vulnerabilities
- TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
- TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
- TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
- TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
- TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
- TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-36129 · CVE Program
- CVE-2022-36129 · NVD
- FIRST EPSS
- GHSA-c8mv-ccvj-9h5q · GitHub Advisory Database · CC BY 4.0
- CVE-2022-36129 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences