An issue was discovered in the HTTP FileResponse class in Django 3.2 before 3.2.15 and…
Priority MEDIUM 40CWE-494Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-494.
Summary
An issue was discovered in the HTTP FileResponse class in Django 3.2 before 3.2.15 and 4.0 before 4.0.7. An application is vulnerable to a reflected file download (RFD) attack that sets the Content-Disposition header of a FileResponse when the filename is derived from user-supplied input.
Why it matters now
EPSS 0.00935 61st percentileScored 2026-11-07
Fix Fixed Django (PyPI): 3.2.15, 4.0.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 3.2.15 | 3.2.15 | Patch available | GHSA-8x94-hmjh-97hq |
| — | Django (PyPI) | 4.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-8x94-hmjh-97hq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 3.2.15 Fixed in 3.2.15 Patch available GHSA-8x94-hmjh-97hq
- Django (PyPI) Vendor— Affected 4.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-8x94-hmjh-97hq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 3.2 to before 3.2.15; 4.0 to before 4.0.7 | Vulnerable | djangoproject |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 3.2 to before 3.2.15; 4.0 to before 4.0.7 Vulnerable ·djangoproject
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-8x94-hmjh-97hq Django (PyPI) Fixed in 3.2.15 Advisory →
- Fix · GHSA-8x94-hmjh-97hq Django (PyPI) Fixed in 4.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36359
- 2026-10-03 Alias added: GHSA-8x94-hmjh-97hq
References
Patch 3
Advisory 6
Other 10
- https://github.com/django/django/commit/b3e4494d759202a3b6bf247fd34455bf13be5b80
- https://github.com/django/django/commit/b7d9529cbe0af4adabb6ea5d01ed8dcce3668fb3
- https://github.com/django/django/commit/bd062445cffd3f6cc6dcd20d13e2abed818fa173
- https://docs.djangoproject.com/en/4.0/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2022-245.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HWY6DQWRVBALV73BPUVBXC3QIYUM24IK
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LTZVAKU5ALQWOKFTPISE257VCVIYGFQI
- https://security.netapp.com/advisory/ntap-20220915-0008
- https://www.djangoproject.com/weblog/2022/aug/03/security-releases
Sources
- CVE-2022-36359 · CVE Program
- CVE-2022-36359 · NVD
- FIRST EPSS
- GHSA-8x94-hmjh-97hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences