Cross-site scripting in IPFire
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Multiple stored cross-site scripting vulnerabilities in the web user interface of IPFire versions prior to 2.27 allows a remote authenticated attacker with administrative privilege to inject an arbitrary script.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00928 60th percentileScored 2026-11-07
Fix Fixed IPFire (IPFire Project): 2.27
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| IPFire Project | IPFire | before 2.27 | 2.27 | Patch available | CNA |
- IPFire VendorIPFire Project Affected before 2.27 Fixed in 2.27 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ipfire:ipfire:*:*:*:*:*:*:*:* | before 2.27 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update159:*:*:*:*:*:* | 2.27 core_update159 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update160:*:*:*:*:*:* | 2.27 core_update160 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update161:*:*:*:*:*:* | 2.27 core_update161 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update162:*:*:*:*:*:* | 2.27 core_update162 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update163:*:*:*:*:*:* | 2.27 core_update163 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update164:*:*:*:*:*:* | 2.27 core_update164 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update165:*:*:*:*:*:* | 2.27 core_update165 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update166:*:*:*:*:*:* | 2.27 core_update166 | Vulnerable | IPFire.org |
| cpe:2.3:a:ipfire:ipfire:2.27:core_update167:*:*:*:*:*:* | 2.27 core_update167 | Vulnerable | IPFire.org |
- cpe:2.3:a:ipfire:ipfire:*:*:*:*:*:*:*:* Versions before 2.27 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update159:*:*:*:*:*:* Versions 2.27 core_update159 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update160:*:*:*:*:*:* Versions 2.27 core_update160 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update161:*:*:*:*:*:* Versions 2.27 core_update161 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update162:*:*:*:*:*:* Versions 2.27 core_update162 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update163:*:*:*:*:*:* Versions 2.27 core_update163 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update164:*:*:*:*:*:* Versions 2.27 core_update164 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update165:*:*:*:*:*:* Versions 2.27 core_update165 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update166:*:*:*:*:*:* Versions 2.27 core_update166 Vulnerable ·IPFire.org
- cpe:2.3:a:ipfire:ipfire:2.27:core_update167:*:*:*:*:*:* Versions 2.27 core_update167 Vulnerable ·IPFire.org
Remediation
- Fix · CNA IPFire (IPFire Project) Fixed in 2.27
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36368
- 2026-10-03 Alias added: GHSA-488g-whpv-px3q
References
More IPFire Project vulnerabilities
- TI-2025-24276 IPFire < 2.19 Core Update 101 proxy.cgi RCE CVSS 4.0HIGH 8.7
Sources
- CVE-2022-36368 · CVE Program
- CVE-2022-36368 · NVD
- FIRST EPSS
- GHSA-488g-whpv-px3q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences