Cross-site request forgery in Jenkins Git Plugin
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Git Plugin 4.11.3 and earlier allows attackers to trigger builds of jobs configured to use an attacker-specified Git repository and to cause them to check out an attacker-specified commit.
Why it matters now
EPSS 0.0074 54th percentileScored 2026-11-07
Fix Partial Jenkins Git Plugin (Jenkins project): 4.9.3org.jenkins-ci.plugins:git (Maven): 4.11.4Red Hat: 3 advisoriesRed Hat: 3 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Git Plugin | up to 4.11.3 | 4.9.3 | Patch available | CNA |
| — | org.jenkins-ci.plugins:git (Maven) | before 4.11.4 | 4.11.4 | Patch available | GHSA-8xwj-2wgh-gprh |
- Jenkins Git Plugin VendorJenkins Affected up to 4.11.3 Fixed in 4.9.3 Patch available CNA
- org.jenkins-ci.plugins:git (Maven) Vendor— Affected before 4.11.4 Fixed in 4.11.4 Patch available GHSA-8xwj-2wgh-gprh
Remediation
- Fix · CNA Jenkins Git Plugin (Jenkins project) Fixed in 4.9.3
- Fix · GHSA-8xwj-2wgh-gprh org.jenkins-ci.plugins:git (Maven) Fixed in 4.11.4 Advisory →
Red Hat 3 advisories
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
- RHSA-2023:0560 Released 2023-02-08 · Red Hat rating CriticalOpenShift Container Platform 4.10.51 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
- RHSA-2023:0017 Released 2023-01-12 · Red Hat rating ImportantOpenShift Container Platform 4.8.56 packages and security update
- Red Hat OpenShift Container Platform 4.8 jenkins-2-plugins-4.8.1672842762-1.el8, jenkins-2.361.1.1672840472-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0560 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2023:0017 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 3 products
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36882
- 2026-10-03 Alias added: GHSA-8xwj-2wgh-gprh
References
More Jenkins Git vulnerabilities
- TI-2022-17098 Missing authorization in Jenkins Git Plugin CVSS 3.1HIGH 7.5
- TI-2022-13003 Path traversal in Jenkins Git Plugin CVSS 3.1HIGH 7.5
- TI-2017-14429 Git Plugin connects to a user-specified Git repository as part of form validation. CVSS 3.0HIGH 7.5
- TI-2022-18196 Insufficiently protected credentials in Jenkins Git Plugin CVSS 3.1MEDIUM 6.5
- TI-2018-15763 An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and… CVSS 3.0MEDIUM 5.3
- TI-2021-04764 Improper output encoding in Jenkins Git Plugin CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-36882 · CVE Program
- CVE-2022-36882 · NVD
- FIRST EPSS
- GHSA-8xwj-2wgh-gprh · GitHub Advisory Database · CC BY 4.0
- CVE-2022-36882 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences