Read the docs
TI-2022-17108 Aliases CVE-2022-36893GHSA-pw4g-jcp5-63m9

Missing authorization in Jenkins rpmsign-plugin Plugin

Priority LOW 21CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

Jenkins rpmsign-plugin Plugin 0.5.0 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.

Why it matters now

EPSS 0.00695 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:rpmsign-plugin (Maven): 0.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins rpmsign-plugin Pluginup to 0.5.0—No fix listedCNA
—org.jenkins-ci.plugins:rpmsign-plugin (Maven)before 0.5.10.5.1Patch availableGHSA-pw4g-jcp5-63m9
  • Jenkins rpmsign-plugin Plugin VendorJenkins Affected up to 0.5.0 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:rpmsign-plugin (Maven) Vendor— Affected before 0.5.1 Fixed in 0.5.1 Patch available GHSA-pw4g-jcp5-63m9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:rpmsign-plugin:*:*:*:*:*:jenkins:*:*up to 0.5.0VulnerableJenkins
  • cpe:2.3:a:jenkins:rpmsign-plugin:*:*:*:*:*:jenkins:*:* Versions up to 0.5.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-pw4g-jcp5-63m9 org.jenkins-ci.plugins:rpmsign-plugin (Maven) Fixed in 0.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36893
  2. 2026-10-03 Alias added: GHSA-pw4g-jcp5-63m9

References

Sources