Protection mechanism failure in Jenkins Compuware zAdviser API Plugin
Priority LOW 38CWE-693Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-693.
Summary
Jenkins Compuware zAdviser API Plugin 1.0.3 and earlier does not restrict execution of a controller/agent message to agents, allowing attackers able to control agent processes to retrieve Java system properties.
Why it matters now
EPSS 0.01071 65th percentileScored 2026-11-07
Fix Fixed com.compuware.jenkins:compuware-zadviser-api (Maven): 1.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Compuware zAdviser API Plugin | up to 1.0.3 | — | No fix listed | CNA |
| — | com.compuware.jenkins:compuware-zadviser-api (Maven) | before 1.0.4 | 1.0.4 | Patch available | GHSA-5xp2-7qfc-fwgc |
- Jenkins Compuware zAdviser API Plugin VendorJenkins Affected up to 1.0.3 Fixed in — No fix listed CNA
- com.compuware.jenkins:compuware-zadviser-api (Maven) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-5xp2-7qfc-fwgc
Remediation
- Fix · GHSA-5xp2-7qfc-fwgc com.compuware.jenkins:compuware-zadviser-api (Maven) Fixed in 1.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36900
- 2026-10-03 Alias added: GHSA-5xp2-7qfc-fwgc
References
Advisory 3
Sources
- CVE-2022-36900 · CVE Program
- CVE-2022-36900 · NVD
- FIRST EPSS
- GHSA-5xp2-7qfc-fwgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences