Read the docs
TI-2022-17508 Aliases CVE-2022-37454GHSA-6w4m-2xhg-2658

The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and…

Priority HIGH 82CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 3 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-190 and the CVSS impact.

Summary

The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties. This occurs in the sponge function interface.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.07413 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial sha3 (RubyGems): 1.0.5Red Hat: 4 advisoriesRed Hat: 2 fixed, 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
————No fix listedCNA
—pysha3 (PyPI)up to 1.0.2—No fix listedGHSA-6w4m-2xhg-2658
—sha3 (RubyGems)before 1.0.51.0.5Patch availableGHSA-6w4m-2xhg-2658
  • — Vendor— Affected — Fixed in — No fix listed CNA
  • pysha3 (PyPI) Vendor— Affected up to 1.0.2 Fixed in — No fix listed GHSA-6w4m-2xhg-2658
  • sha3 (RubyGems) Vendor— Affected before 1.0.5 Fixed in 1.0.5 Patch available GHSA-6w4m-2xhg-2658

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:extended_keccak_code_package_project:extended_keccak_code_package:-:*:*:*:*:*:*:*not specified by NVDVulnerableExtended Keccak Code Package Project
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*7.2.0 to before 7.4.33; 8.0.0 to before 8.0.25; 8.1.0 to before 8.1.12VulnerablePHP
cpe:2.3:a:python:python:*:*:*:*:*:*:*:*3.6.0 to before 3.7.16; 3.8.0 to before 3.8.16; 3.9.0 to before 3.9.16; 3.10.0 to before 3.10.9Vulnerablepython-pillow
cpe:2.3:a:sha3_project:sha3:*:*:*:*:*:ruby:*:*before 1.0.5VulnerableSha3 Project
cpe:2.3:a:pysha3_project:pysha3:*:*:*:*:*:*:*:*all versionsVulnerablePysha3 Project
cpe:2.3:a:pypy:pypy:*:*:*:*:*:*:*:*7.0.0VulnerablePyPy
  • cpe:2.3:a:extended_keccak_code_package_project:extended_keccak_code_package:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Extended Keccak Code Package Project
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.2.0 to before 7.4.33; 8.0.0 to before 8.0.25; 8.1.0 to before 8.1.12 Vulnerable ·PHP
  • cpe:2.3:a:python:python:*:*:*:*:*:*:*:* Versions 3.6.0 to before 3.7.16; 3.8.0 to before 3.8.16; 3.9.0 to before 3.9.16; 3.10.0 to before 3.10.9 Vulnerable ·python-pillow
  • cpe:2.3:a:sha3_project:sha3:*:*:*:*:*:ruby:*:* Versions before 1.0.5 Vulnerable ·Sha3 Project
  • cpe:2.3:a:pysha3_project:pysha3:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·Pysha3 Project
  • cpe:2.3:a:pypy:pypy:*:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·PyPy

Remediation

  • Fix · GHSA-6w4m-2xhg-2658 sha3 (RubyGems) Fixed in 1.0.5 Advisory →

Red Hat 4 advisories

  • RHSA-2023:2903 Released 2023-05-16 · Red Hat rating Moderate
    php:7.4 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.3.0+6678+b09f589e.noarch::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.aarch64::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.ppc64le::php:7.4 +47
  • RHSA-2023:2417 Released 2023-05-09 · Red Hat rating Moderate
    php:8.1 security update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.21-1.module+el9.1.0.z+15477+cb86791d.noarch::php:8.1, php-8.1.14-1.module+el9.2.0+17911+b059dfc2.aarch64::php:8.1, php-8.1.14-1.module+el9.2.0+17911+b059dfc2.ppc64le::php:8.1 +47
  • RHSA-2023:0965 Released 2023-02-28 · Red Hat rating Moderate
    php security update
    • Red Hat Enterprise Linux AppStream (v. 9) php-8.0.27-1.el9_1, php-bcmath-8.0.27-1.el9_1, php-cli-8.0.27-1.el9_1 +22
Show 1 more Red Hat advisories
  • RHSA-2023:0848 Released 2023-02-21 · Red Hat rating Moderate
    php:8.0 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.20-1.module+el8.6.0+13671+84712317.noarch::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.aarch64::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.ppc64le::php:8.0 +47

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Software CollectionsAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:0848, RHSA-2023:2903
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:0965, RHSA-2023:2417
Not affected: 5 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat Software Collections

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-37454
  2. 2026-10-03 Alias added: GHSA-6w4m-2xhg-2658

References

Sources