Read the docs
TI-2022-18455 Aliases CVE-2022-39063GHSA-963g-g6x3-46cf

When Open5GS UPF receives a PFCP Session Establishment Request, it stores related values…

Priority LOW 35CWE-676Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

When Open5GS UPF receives a PFCP Session Establishment Request, it stores related values for building the PFCP Session Establishment Response. Once UPF receives a request, it gets the f_teid_len from incoming message, and then uses it to copy data from incoming message to struct f_teid without checking the maximum length. If the pdi.local_f_teid.len exceeds the maximum length of the struct of f_teid, the memcpy() overwrites the fields (e.g., f_teid_len) after f_teid in the pdr struct. After parsing the request, the UPF starts to build a response. The f_teid_len with its overwritten value is used as a length for memcpy(). A segmentation fault occurs, as a result of a memcpy(), if this overwritten value is large enough.

Why it matters now

EPSS 0.01205 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Open5GS (Open5GS): 2.4.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Open5GSOpen5GSbefore 2.4.92.4.9Patch availableCNA
  • Open5GS VendorOpen5GS Affected before 2.4.9 Fixed in 2.4.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:*up to 2.4.9VulnerableOpen5GS
  • cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:* Versions up to 2.4.9 Vulnerable ·Open5GS

Remediation

  • Fix · CNA Open5GS (Open5GS) Fixed in 2.4.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39063
  2. 2026-10-03 Alias added: GHSA-963g-g6x3-46cf

References

  • TI-2024-26883 open5gs v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-26882 Open5GS v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-22649 Open5GS MME versions <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18757 Open5GS MME versions <= 2.6.4 contain a reachable assertion in the `Uplink NAS Transport`… CVSS 3.1HIGH 8.6
  • TI-2023-18755 Open5GS MME version <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18754 Open5GS MME versions <= 2.6.4 contain an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
See all 153 →

Sources