Bifrost users using basic authntication can bypass write permission limit
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Bifrost is a middleware package which can synchronize MySQL/MariaDB binlog data to other types of databases. Versions 1.8.6-release and prior are vulnerable to authentication bypass when using HTTP basic authentication. This may allow group members who only have read permissions to write requests when they are normally forbidden from doing so. Version 1.8.7-release contains a patch. There are currently no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| brokercap | Bifrost | before 1.8.7-release | 1.8.7-release | Patch available | CNA |
| — | github.com/brokercap/Bifrost (Go) | before 1.8.7-release | 1.8.7-release | Patch available | GHSA-p6fh-xc6r-g5hw |
- Bifrost Vendorbrokercap Affected before 1.8.7-release Fixed in 1.8.7-release Patch available CNA
- github.com/brokercap/Bifrost (Go) Vendor— Affected before 1.8.7-release Fixed in 1.8.7-release Patch available GHSA-p6fh-xc6r-g5hw
Remediation
- Fix · CNA Bifrost (brokercap) Fixed in 1.8.7-release
- Fix · GHSA-p6fh-xc6r-g5hw github.com/brokercap/Bifrost (Go) Fixed in 1.8.7-release Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39219
- 2026-10-03 Alias added: GHSA-p6fh-xc6r-g5hw
References
More Xbifrost Bifrost vulnerabilities
- TI-2022-18643 Brokercap Bifrost vulnerable to authentication bypass for admin and monitor user groups CVSS 3.1HIGH 8.8
Sources
- CVE-2022-39219 · CVE Program
- CVE-2022-39219 · NVD
- FIRST EPSS
- GHSA-p6fh-xc6r-g5hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences