Security issue in fhir-works-on-aws-authz-smart
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | fhir-works-on-aws-authz-smart | > 3.1.0, < 3.1.3 | — | No fix listed | CNA |
| — | fhir-works-on-aws-authz-smart (npm) | 3.1.1 to before 3.1.3 | 3.1.3 | Patch available | GHSA-vv7x-7w4m-q72f |
- fhir-works-on-aws-authz-smart VendorAWS Affected > 3.1.0, < 3.1.3 Fixed in — No fix listed CNA
- fhir-works-on-aws-authz-smart (npm) Vendor— Affected 3.1.1 to before 3.1.3 Fixed in 3.1.3 Patch available GHSA-vv7x-7w4m-q72f
Remediation
- Fix · GHSA-vv7x-7w4m-q72f fhir-works-on-aws-authz-smart (npm) Fixed in 3.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39230
- 2026-10-03 Alias added: GHSA-vv7x-7w4m-q72f
References
Advisory 2
Sources
- CVE-2022-39230 · CVE Program
- CVE-2022-39230 · NVD
- FIRST EPSS
- GHSA-vv7x-7w4m-q72f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences