Discourse vulnerable to incomplete quote causing a topic to crash in the browser
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Discourse is an open source discussion platform. Starting with version 2.9.0.beta5 and prior to version 2.9.0.beta10, an incomplete quote can generate a JavaScript error which will crash the current page in the browser in some cases. Version 2.9.0.beta10 added a fix and tests to ensure incomplete quotes won't break the app. As a workaround, the quote can be fixed via the rails console.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | 2.9.0.beta5 to before 2.9.0.beta10 | 2.9.0.beta10 | Patch available | CNA |
- discourse Vendordiscourse Affected 2.9.0.beta5 to before 2.9.0.beta10 Fixed in 2.9.0.beta10 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:*:*:*:* | 2.9.0 beta5 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:*:*:*:* | 2.9.0 beta6 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:*:*:*:* | 2.9.0 beta7 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:*:*:*:* | 2.9.0 beta8 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta9:*:*:*:*:*:* | 2.9.0 beta9 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:*:*:*:* Versions 2.9.0 beta5 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:*:*:*:* Versions 2.9.0 beta6 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:*:*:*:* Versions 2.9.0 beta7 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:*:*:*:* Versions 2.9.0 beta8 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta9:*:*:*:*:*:* Versions 2.9.0 beta9 Vulnerable ·discourse
Remediation
- Fix · CNA discourse (discourse) Fixed in 2.9.0.beta10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39232
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences