Read the docs
TI-2022-18615 Aliases CVE-2022-39238

Improper Authentication in Arvados when using PAM as identity provider

Priority LOW 39CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.

Summary

Arvados is an open source platform for managing and analyzing biomedical big data. In versions prior to 2.4.3, when using Portable Authentication Modules (PAM) for user authentication, if a user presented valid credentials but the account is disabled or otherwise not allowed to access the host (such as an expired password), it would still be accepted for access to Arvados. Other authentication methods (LDAP, OpenID Connect) supported by Arvados are not affected by this flaw. This issue is patched in version 2.4.3. Workaround for this issue is to migrate to a different authentication method supported by Arvados, such as LDAP.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00503 43rd percentileScored 2026-11-07
Fix Fixed arvados (arvados): 2.4.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
arvadosarvadosbefore 2.4.32.4.3Patch availableCNA
  • arvados Vendorarvados Affected before 2.4.3 Fixed in 2.4.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:arvados:arvados:*:*:*:*:*:ruby:*:*before 2.4.3Vulnerablearvados
  • cpe:2.3:a:arvados:arvados:*:*:*:*:*:ruby:*:* Versions before 2.4.3 Vulnerable ·arvados

Remediation

  • Fix · CNA arvados (arvados) Fixed in 2.4.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39238

References

  • TI-2022-16431 Authenticated remote code execution due to insecure deserialization (GHSL-2022-063) CVSS 3.1HIGH 8.8

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences